Bug 1282618 - cfme cloud-init broken with rhev 3.5.5
cfme cloud-init broken with rhev 3.5.5
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
All All
high Severity high
: GA
: 5.6.0
Assigned To: Brandon Dunne
luke couzens
: ZStream
Depends On:
Blocks: 1290175 1328439
  Show dependency treegraph
 
Reported: 2015-11-16 17:04 EST by Josh Carter
Modified: 2016-06-29 11:08 EDT (History)
13 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290175 1328439 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:08:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 14:50:04 EDT

  None (edit)
Description Josh Carter 2015-11-16 17:04:00 EST
Description of problem:

Issue : Customizations (cloudinit scripts) are not getting injected to the provisioned VM/VMs. 

Investigation done : Issue is reproducible locally. Even with the customization data provider,
VMs are getting provisioned with no cloud-init payload attached. 


- Provisioned vm disk configuration. (no payload disk/floppy attached)  

[root@dell-per210-3 ~]# virsh -r domblklist vm005
Target     Source
------------------------------------------------
hdc        -
vda        /rhev/data-center/296a1353-c567-4ed1-9394-d59cd5fcf566/ea4dec1c-22f5-45a5-9994-f0dc0b01425a/images/51036b3e-b05d-4e91-bfd5-5d26206ca4e2/fbff4e72-eea8-4cd4-9dc1-372a65554e8b


- In API, initialization data is there but payload is not generated 

<initialization><regenerate_ssh_keys>false</regenerate_ssh_keys><nic_configurations/><custom_script>runcmd:
- touch /eprasad1.txt
- echo "test" > /eprasad1.txt
</custom_script></initialization><placement_policy>


Reproducer access :  
CFME : https://10.65.223.177 (admin:smartvm)
RHEVM : https://10.65.209.226/ovirt-engine (admin@internal:redhat.com)

NOTE : Issue is reproducible only with  RHEVM 3.5.5-0.1. With older versions, Customization is working 
perfectly fine. 

It could be this patch as pointed by the customer that is causing the problem : https://gerrit.ovirt.org/#/c/43385/


Version-Release number of selected component (if applicable): 5.4.3 & 5.5 beta 2


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Greg McCullough 2015-11-16 17:35:19 EST
Drew - Please work with Brandon on this issue.
Comment 3 Brandon Dunne 2015-11-20 14:24:48 EST
Seems related to https://bugzilla.redhat.com/show_bug.cgi?id=1269534

Even with the "use_cloud_init" change, no success provisioning to RHEV 3.5.5
Comment 5 Greg McCullough 2015-11-24 09:00:37 EST
Opened RHEVM Bug 1284654 while working on this issue.
Comment 6 Brandon Dunne 2015-11-24 10:28:38 EST
Based on feedback from https://bugzilla.redhat.com/show_bug.cgi?id=1269534#c17 it seems we will be unable to provision using cloud-init on RHEV 3.5.5 due to changes in the RHEV API at this version.

I am currently testing against RHEV 3.5.6 and will make any changes required to restore the functionality that we had before RHEV 3.5.5 API change.
Comment 9 CFME Bot 2015-12-15 14:55:31 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/407dbdc450f6f0c8dcae90c120fd1cc7bb106fb2

commit 407dbdc450f6f0c8dcae90c120fd1cc7bb106fb2
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Wed Nov 25 12:24:39 2015 -0500
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Tue Dec 15 10:26:49 2015 -0500

    Send use_cloud_init to start when provisioning RHEV 3.5.5+ with cloud-init
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1282618
    
    Initialization data no longer used in cloud-init user data:
    https://bugzilla.redhat.com/show_bug.cgi?id=1269534
    
    Version field incorrect:
    https://bugzilla.redhat.com/show_bug.cgi?id=1284654

 .../providers/redhat/infra_manager/provision/configuration.rb |  4 ++++
 .../providers/redhat/infra_manager/provision/state_machine.rb | 11 +++++++++++
 gems/pending/Gemfile                                          |  2 +-
 3 files changed, 16 insertions(+), 1 deletion(-)
Comment 12 CFME Bot 2015-12-17 16:24:34 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7445e4208eb360a6c6775ced847d3d9a957b3165

commit 7445e4208eb360a6c6775ced847d3d9a957b3165
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Wed Nov 25 12:24:39 2015 -0500
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Wed Dec 16 18:12:33 2015 -0500

    Send use_cloud_init to start when provisioning RHEV 3.5.5+ with cloud-init
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1282618
    
    Initialization data no longer used in cloud-init user data:
    https://bugzilla.redhat.com/show_bug.cgi?id=1269534
    
    Version field incorrect:
    https://bugzilla.redhat.com/show_bug.cgi?id=1284654

 .../providers/redhat/infra_manager/provision/configuration.rb |  4 ++++
 .../providers/redhat/infra_manager/provision/state_machine.rb | 11 +++++++++++
 gems/pending/Gemfile                                          |  2 +-
 3 files changed, 16 insertions(+), 1 deletion(-)
Comment 15 luke couzens 2016-06-15 18:22:29 EDT
verified in 5.6.0.10 with rhev 3.5.7-0.1
Comment 17 errata-xmlrpc 2016-06-29 11:08:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.