Bug 1290243 - SimplePagedResults -- in the search error case, simple paged results slot was not released.
Summary: SimplePagedResults -- in the search error case, simple paged results slot was...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base
Version: 6.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
Petr Bokoc
URL:
Whiteboard:
Depends On:
Blocks: 1290722
TreeView+ depends on / blocked
 
Reported: 2015-12-09 22:32 UTC by Noriko Hosoi
Modified: 2020-09-13 21:36 UTC (History)
6 users (show)

Fixed In Version: 389-ds-base-1.2.11.15-71.el6
Doc Type: Bug Fix
Doc Text:
Simple paged results slots are now being correctly released after search failure Previously, if a simple paged results search failed in the Directory Server backend, its slot was not released, which caused the connection object to accumulate unreleased slots over time. This problem has been fixed, and slots are now correctly released in the event of a search failure.
Clone Of:
: 1290722 (view as bug list)
Environment:
Last Closed: 2016-05-10 19:22:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 1706 0 None None None 2020-09-13 21:36:40 UTC
Red Hat Product Errata RHBA-2016:0737 0 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2016-05-10 22:29:13 UTC

Description Noriko Hosoi 2015-12-09 22:32:18 UTC
Reproducer:
{{{
1. Install and configure the Directory Server WITHOUT a suffix "o=redhat".
2. Compile paged_def.c after adjusting the Directory Manager's password.
   Note: the suffix o=redhat should not be adjusted.
   https://fedorahosted.org/389/attachment/ticket/47707/paged_def.c
3. Run the compiled paged_def.
4. The access log would contain the result line with "err=32" AND a large pr_idx. E.g.,
> [..] conn=1 op=130870 RESULT err=32 tag=101 nentries=0 etime=0 notes=P pr_idx=43623
}}}

Comment 4 Amita Sharma 2015-12-31 10:48:08 UTC
This is fixed.
[31/Dec/2015:05:46:59 -0500] conn=1 op=3036 RESULT err=0 tag=101 nentries=0 etime=0 notes=P pr_idx=0 in access long after a long time execution.

[root@mgmt3 export]# rpm -qa | grep 389
389-ds-base-libs-1.2.11.15-71.el6.x86_64
389-ds-base-1.2.11.15-71.el6.x86_64
389-ds-base-debuginfo-1.2.11.15-71.el6.x86_64
389-ds-base-devel-1.2.11.15-71.el6.x86_64

Comment 6 errata-xmlrpc 2016-05-10 19:22:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0737.html


Note You need to log in before you can comment on or make changes to this bug.