Bug 1290722
| Summary: | SimplePagedResults -- in the search error case, simple paged results slot was not released. | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Linux 6 | Reporter: | Jan Kurik <jkurik> |
| Component: | 389-ds-base | Assignee: | Noriko Hosoi <nhosoi> |
| Status: | CLOSED ERRATA | QA Contact: | Viktor Ashirov <vashirov> |
| Severity: | urgent | Docs Contact: | |
| Priority: | urgent | ||
| Version: | 6.0 | CC: | amsharma, jgalipea, msauton, nhosoi, nkinder, rmeggins |
| Target Milestone: | rc | Keywords: | ZStream |
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | 389-ds-base-1.2.11.15-69.el6_7 | Doc Type: | Bug Fix |
| Doc Text: |
Previously, if a simple paged results search failed in the back end, the simple paged results slot was not released. Consequently, the simple paged results slots in a connection object could be accumulated. With this update, the simple paged results slot is released correctly when a search fails, and unused simple paged results slots are no longer left in a connection object.
|
Story Points: | --- |
| Clone Of: | 1290243 | Environment: | |
| Last Closed: | 2016-02-09 08:44:57 UTC | Type: | --- |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
| Bug Depends On: | 1290243 | ||
| Bug Blocks: | |||
|
Description
Jan Kurik
2015-12-11 08:52:15 UTC
[root@mgmt8 ~]# cat /etc/redhat-release Red Hat Enterprise Linux Server release 6.7 (Santiago) [root@mgmt8 ~]# rpm -qa | grep 389 389-ds-base-1.2.11.15-69.el6_7.x86_64 389-ds-base-libs-1.2.11.15-69.el6_7.x86_64 [08/Jan/2016:04:29:39 -0500] conn=5 op=15570 SRCH base="o=redhat" scope=2 filter="(cn=user100*)" attrs=ALL [08/Jan/2016:04:29:39 -0500] conn=5 op=15570 RESULT err=0 tag=101 nentries=0 etime=0 notes=P pr_idx=0 Hence VERIFIED. Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://rhn.redhat.com/errata/RHBA-2016-0147.html |