Bug 1290254 - [RFE][OpsTools] We need a performance monitoring tool deployed by director
[RFE][OpsTools] We need a performance monitoring tool deployed by director
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
All Linux
high Severity high
: Upstream M3
: 11.0 (Ocata)
Assigned To: Lars Kellogg-Stedman
Leonid Natapov
: FutureFeature, InstallerIntegration, Triaged
: 1290252 (view as bug list)
Depends On:
Blocks: 1336839 1402132 1427384
  Show dependency treegraph
 
Reported: 2015-12-09 18:03 EST by Nick Barcet
Modified: 2017-05-17 15:25 EDT (History)
19 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.20170218023452.edbaaa9.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-17 15:25:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 411048 None None None 2016-12-20 09:16 EST

  None (edit)
Description Nick Barcet 2015-12-09 18:03:36 EST
We need to deploy the performance monitoring solution that Ggillies has put together.
http://file.bne.redhat.com/~ggillies/optools_doc/

Use case:
As an operator, I need to be able to verify the performance of an OpenStack deployment

Satisfaction criterias:
* solution is automatically deployed when the appropriate option is activated
* solution is documented
Comment 1 Nick Barcet 2015-12-09 18:24:31 EST
*** Bug 1290252 has been marked as a duplicate of this bug. ***
Comment 3 Paul Christensen 2016-08-08 15:24:16 EDT
Would it be possible to get some guidance on this RFE in the DFG? Overall confidence in Newton is 0%. Is that accruate?
Comment 4 Jaromir Coufal 2016-08-10 16:38:08 EDT
Performance monitoring is planned to be integrated after Newton cycle. Adding Maria for proper scoping.
Comment 7 Lars Kellogg-Stedman 2016-12-20 09:24:12 EST
In OSP11 we will deliver collectd integration with tripleo, including the ability to link collectd on the overcloud to a remote collectd or graphite instance, but we will not be providing a pre-configured set of metrics.  There will be facilities for the operator to provide a metric configuration as part of the tripleo deployment.
Comment 14 Martin Magr 2017-02-02 05:23:57 EST
*** Bug 1411926 has been marked as a duplicate of this bug. ***
Comment 21 Leonid Natapov 2017-03-07 07:34:01 EST
Performance Monitoring can be deployed by director.

tested with openstack-tripleo-heat-templates-6.0.0-0.20170222195630.46117f4.el7ost.noarch
Comment 23 errata-xmlrpc 2017-05-17 15:25:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245

Note You need to log in before you can comment on or make changes to this bug.