Bug 1290270 - Several intermittent regression failures
Several intermittent regression failures
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
mainline
All All
medium Severity medium
: ---
: ---
Assigned To: Michael Adam
: Reopened, Triaged
: 1289973 (view as bug list)
Depends On:
Blocks: 1290532
  Show dependency treegraph
 
Reported: 2015-12-09 19:24 EST by Michael Adam
Modified: 2016-06-16 09:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290532 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:50:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Adam 2015-12-09 19:24:43 EST
Description of problem:

There are currently several spurious tests.
We should bundle adding them to the bad test list
into one patch so that they don't prevent each other's
regression runs from succeeding...

Failing on Linux:
=================

tests/basic/afr/split-brain-healing.t:
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16680/consoleFull

tests/basic/afr/sparse-file-self-heal.t:
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull

tests/basic/afr/replace-brick-self-heal.t:
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16681/consoleFull

tests/bugs/tier/bug-1279376-rename-demoted-file.t:
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16675/consoleFull

possibly this one (thows core):
tests/bugs/snapshot/bug-1140162-file-snapshot-features-encrypt-opts-validation.t
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16674/consoleFull

Failing on NetBSD:
==================

tests/basic/afr/arbiter-statfs.t:
  https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12551/consoleFull

tests/features/weighted-rebalance.t:
  https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12538/consoleFull
Comment 1 Vijay Bellur 2015-12-09 19:30:59 EST
REVIEW: http://review.gluster.org/12933 (tests: mark several tests as bad) posted (#1) for review on master by Michael Adam (obnox@samba.org)
Comment 2 Vijay Bellur 2015-12-09 20:57:34 EST
COMMIT: http://review.gluster.org/12933 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit d07983bff768e919fd867c27f8cca9c346e4eca9
Author: Michael Adam <obnox@samba.org>
Date:   Thu Dec 10 01:27:53 2015 +0100

    tests: mark several tests as bad
    
    There are currently several spurious tests.
    We should bundle adding them to the bad test list
    into one patch so that they don't prevent each other's
    regression runs from succeeding...
    
    Failing on Linux:
    =================
    
    tests/basic/afr/split-brain-healing.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16680/consoleFull
    
    tests/basic/afr/sparse-file-self-heal.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull
    
    tests/basic/afr/replace-brick-self-heal.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16681/consoleFull
    
    tests/bugs/tier/bug-1279376-rename-demoted-file.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16675/consoleFull
    
    this one thows core:
    tests/bugs/snapshot/bug-1140162-file-snapshot-features-encrypt-opts-validation.t
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16674/consoleFull
    
    Failing on NetBSD:
    ==================
    
    tests/basic/afr/arbiter-statfs.t:
      https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12551/consoleFull
    
    tests/features/weighted-rebalance.t:
      https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12538/consoleFull
    
    Change-Id: I1f48d5631d761b5d3e736bfd918f483bdbd36c5a
    BUG: 1290270
    Signed-off-by: Michael Adam <obnox@samba.org>
    Reviewed-on: http://review.gluster.org/12933
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 3 Ravishankar N 2015-12-19 00:14:40 EST
*** Bug 1289973 has been marked as a duplicate of this bug. ***
Comment 4 Niels de Vos 2016-06-16 09:50:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.