Bug 1290532 - Several intermittent regression failures
Several intermittent regression failures
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.6
All All
low Severity low
: ---
: ---
Assigned To: Michael Adam
: Triaged
Depends On: 1290270
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 12:51 EST by Michael Adam
Modified: 2016-04-19 03:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290270
Environment:
Last Closed: 2016-03-10 02:43:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Adam 2015-12-10 12:51:34 EST
+++ This bug was initially created as a clone of Bug #1290270 +++

Description of problem:

There are currently several spurious tests.
We should bundle adding them to the bad test list
into one patch so that they don't prevent each other's
regression runs from succeeding...

Failing on Linux:
=================

tests/basic/afr/split-brain-healing.t:
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16680/consoleFull

tests/basic/afr/sparse-file-self-heal.t:
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull

tests/basic/afr/replace-brick-self-heal.t:
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16681/consoleFull

tests/bugs/tier/bug-1279376-rename-demoted-file.t:
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16675/consoleFull

possibly this one (thows core):
tests/bugs/snapshot/bug-1140162-file-snapshot-features-encrypt-opts-validation.t
  https://build.gluster.org/job/rackspace-regression-2GB-triggered/16674/consoleFull

Failing on NetBSD:
==================

tests/basic/afr/arbiter-statfs.t:
  https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12551/consoleFull

tests/features/weighted-rebalance.t:
  https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12538/consoleFull

--- Additional comment from Vijay Bellur on 2015-12-09 19:30:59 EST ---

REVIEW: http://review.gluster.org/12933 (tests: mark several tests as bad) posted (#1) for review on master by Michael Adam (obnox@samba.org)

--- Additional comment from Vijay Bellur on 2015-12-09 20:57:34 EST ---

COMMIT: http://review.gluster.org/12933 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit d07983bff768e919fd867c27f8cca9c346e4eca9
Author: Michael Adam <obnox@samba.org>
Date:   Thu Dec 10 01:27:53 2015 +0100

    tests: mark several tests as bad
    
    There are currently several spurious tests.
    We should bundle adding them to the bad test list
    into one patch so that they don't prevent each other's
    regression runs from succeeding...
    
    Failing on Linux:
    =================
    
    tests/basic/afr/split-brain-healing.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16680/consoleFull
    
    tests/basic/afr/sparse-file-self-heal.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull
    
    tests/basic/afr/replace-brick-self-heal.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16681/consoleFull
    
    tests/bugs/tier/bug-1279376-rename-demoted-file.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16675/consoleFull
    
    this one thows core:
    tests/bugs/snapshot/bug-1140162-file-snapshot-features-encrypt-opts-validation.t
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16674/consoleFull
    
    Failing on NetBSD:
    ==================
    
    tests/basic/afr/arbiter-statfs.t:
      https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12551/consoleFull
    
    tests/features/weighted-rebalance.t:
      https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12538/consoleFull
    
    Change-Id: I1f48d5631d761b5d3e736bfd918f483bdbd36c5a
    BUG: 1290270
    Signed-off-by: Michael Adam <obnox@samba.org>
    Reviewed-on: http://review.gluster.org/12933
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 1 Vijay Bellur 2015-12-10 12:59:17 EST
REVIEW: http://review.gluster.org/12941 (tests: mark several tests as bad) posted (#1) for review on release-3.7 by Michael Adam (obnox@samba.org)
Comment 2 Vijay Bellur 2015-12-11 09:11:05 EST
COMMIT: http://review.gluster.org/12941 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 61e08fa705fad33243fd1da7b4ace4f14900d567
Author: Michael Adam <obnox@samba.org>
Date:   Thu Dec 10 01:27:53 2015 +0100

    tests: mark several tests as bad
    
    There are currently several spurious tests.
    We should bundle adding them to the bad test list
    into one patch so that they don't prevent each other's
    regression runs from succeeding...
    
    Failing on Linux:
    =================
    
    tests/basic/afr/split-brain-healing.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16680/consoleFull
    
    tests/basic/afr/sparse-file-self-heal.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16682/consoleFull
    
    tests/basic/afr/replace-brick-self-heal.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16681/consoleFull
    
    tests/bugs/tier/bug-1279376-rename-demoted-file.t:
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16675/consoleFull
    
    this one thows core:
    tests/bugs/snapshot/bug-1140162-file-snapshot-features-encrypt-opts-validation.t
      https://build.gluster.org/job/rackspace-regression-2GB-triggered/16674/consoleFull
    
    Failing on NetBSD:
    ==================
    
    tests/basic/afr/arbiter-statfs.t:
      https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12551/consoleFull
    
    tests/features/weighted-rebalance.t:
      https://build.gluster.org/job/rackspace-netbsd7-regression-triggered/12538/consoleFull
    
    > Change-Id: I1f48d5631d761b5d3e736bfd918f483bdbd36c5a
    > BUG: 1290270
    > Signed-off-by: Michael Adam <obnox@samba.org>
    > Reviewed-on: http://review.gluster.org/12933
    > Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    
    (cherry picked from commit d07983bff768e919fd867c27f8cca9c346e4eca9)
    
    Change-Id: I1d390baf143815d7d18e8d0b033edf2de80a2931
    BUG: 1290532
    Signed-off-by: Michael Adam <obnox@samba.org>
    Reviewed-on: http://review.gluster.org/12941
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Kaushal 2016-04-19 03:50:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.