Bug 129034 - [PATCH] rpm doesn't understand redhat-on-armv5teb and redhat-on-armv5tel
[PATCH] rpm doesn't understand redhat-on-armv5teb and redhat-on-armv5tel
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
xscale Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: EasyFix, Patch
Depends On:
Blocks: 129587
  Show dependency treegraph
 
Reported: 2004-08-03 08:07 EDT by Lennert Buytenhek
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 20:59:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suggested fix. (1.84 KB, patch)
2004-08-03 08:09 EDT, Lennert Buytenhek
no flags Details | Diff
Suggested diff to the spec file. (455 bytes, patch)
2004-08-10 12:20 EDT, Lennert Buytenhek
no flags Details | Diff
Suggested fix, new version. (3.45 KB, patch)
2004-08-23 21:10 EDT, Lennert Buytenhek
no flags Details | Diff
Suggested diff to the spec file, new version. (478 bytes, patch)
2004-08-23 21:11 EDT, Lennert Buytenhek
no flags Details | Diff

  None (edit)
Description Lennert Buytenhek 2004-08-03 08:07:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
config.guess supplied with rpm 4.3.1 automatically sets the vendor to
unknown if the arch is arm*, preventing bootstrapping of Fedora 2 on
the armv5te(b) architectures.

Also, rpm won't install noarch RPMS on darmv5te and armv5teb
architectures by default.

Version-Release number of selected component (if applicable):
4.3.1

How reproducible:
Always

Steps to Reproduce:
Hand-build an initial set of packages for the armv5te(b) architecture,
and then try to rpmbuild --rebuild the rpm 4.3.1 source rpm.
    

Actual Results:  Bails out, because /usr/src/unknown instead of
/usr/src/redhat is made by the build+install process.  This happens
because the supplied config.guess forces vendor to be unknown if arch
is arm*, returning armv5te(b)-unknown-linux-gnu instead of
armv5te(b)-redhat-linux-gnu.

Expected Results:  It should have built properly :)

Additional info:
Comment 1 Lennert Buytenhek 2004-08-03 08:09:13 EDT
Created attachment 102385 [details]
Suggested fix.
Comment 2 Lennert Buytenhek 2004-08-10 12:20:46 EDT
Created attachment 102575 [details]
Suggested diff to the spec file.

This patch teaches the spec file to pick up the correct /usr/lib/rpm/arch dir.
Comment 3 Lennert Buytenhek 2004-08-23 21:10:33 EDT
Created attachment 103009 [details]
Suggested fix, new version.

The little-endian arch is more appropriately named armv5tel.  Update patch to
reflect this.
Comment 4 Lennert Buytenhek 2004-08-23 21:11:32 EDT
Created attachment 103010 [details]
Suggested diff to the spec file, new version.

Update to armv5tel.
Comment 5 Jeff Johnson 2005-10-25 20:59:58 EDT
Added in rpm-4.4.3-0.24 (when built). I have no way at all of testing however ...

Note You need to log in before you can comment on or make changes to this bug.