Bug 1290346 - Upgrading to ipa-server-4.2.0-15.el7_2.3 breaks data version check, breaking entire IPA server
Upgrading to ipa-server-4.2.0-15.el7_2.3 breaks data version check, breaking ...
Status: CLOSED DUPLICATE of bug 1290142
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 04:49 EST by Patrick Uiterwijk
Modified: 2015-12-10 05:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 05:05:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrick Uiterwijk 2015-12-10 04:49:28 EST
Description of problem:
After upgrading from ipa-server-4.2.0-15.el7 to 4.2.0-15.el7_2.3, the data version check fails.

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-15.el7_2.3

How reproducible:
Consistent

Steps to Reproduce:
1. Install ipa-server-4.2.0-15.el7
2. Configure ipa
3. Upgrade the package to ipa-server-4.2.0-15.el7_2.3

Actual results:
IPA server fails to start with: IPA version error: data are in newer version than IPA (data version '4.2.0-15.el7', IPA version '4.2.0-15.el7_2.3')

Expected results:
IPA server starts

Additional info:
[root@account log]# ipa-server-upgrade 
session memcached servers not running
IPA server upgrade failed: Inspect /var/log/ipaupgrade.log and run command ipa-server-upgrade manually.
("Unable to execute IPA upgrade: data are in newer version than IPA (data version '4.2.0-15.el7', IPA version '4.2.0-15.el7_2.3')", 1)
Comment 1 Patrick Uiterwijk 2015-12-10 04:54:11 EST
Downgrading to ipa*-4.2.0-15.el7 fixed it, and allowed me to start the instance back up.
Comment 2 Martin Bašti 2015-12-10 05:05:49 EST

*** This bug has been marked as a duplicate of bug 1290142 ***

Note You need to log in before you can comment on or make changes to this bug.