Bug 1290142 - Broken 7.2.0 to 7.2.z upgrade - flawed version comparison
Broken 7.2.0 to 7.2.z upgrade - flawed version comparison
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
Marc Muehlfeld
: ZStream
: 1290346 (view as bug list)
Depends On:
Blocks: 1298100
  Show dependency treegraph
 
Reported: 2015-12-09 13:03 EST by Martin Bašti
Modified: 2016-11-04 01:42 EDT (History)
15 users (show)

See Also:
Fixed In Version: ipa-4.2.0-16.el7
Doc Type: Bug Fix
Doc Text:
The IdM upgrade script now runs successfully Previously, the Identity Management (IdM) server upgrade script failed to detect a version change. As a consequence, upgrading an IdM server failed. This bug has been fixed and the upgrade now succeeds.
Story Points: ---
Clone Of:
: 1298100 (view as bug list)
Environment:
Last Closed: 2016-11-04 01:42:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2085673 None None None Never
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 09:56:18 EDT

  None (edit)
Description Martin Bašti 2015-12-09 13:03:56 EST
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/5535

Obviously it was upgrade to never version.
{{{
2015-12-09T15:21:02Z DEBUG The ipa-server-upgrade command failed, exception: ScriptError: ("Unable to execute IPA upgrade: data are in newer version than IPA (data version '4.2.0-15.el7', IPA version '4.2.0-15.el7_2.3')", 1)
2015-12-09T15:21:02Z ERROR ("Unable to execute IPA upgrade: data are in newer version than IPA (data version '4.2.0-15.el7', IPA version '4.2.0-15.el7_2.3')", 1)
"/var/log/ipaupgrade.log" 54696L, 5389464C  
}}}
Comment 3 Martin Kosek 2015-12-10 04:24:35 EST
The bug manifests in 7.2.0 (ipa-4.2.0-15.el7) to 7.2.z (4.2.0-15.el7_2.3) upgrade. The upgrade does not happen as the version check is flawed and does not detect 7.2.z version as the new one.

The workaround is to run

# ipa-server-upgrade --skip-version-check

after the RPM upgrade and start the service again.
Comment 6 Martin Bašti 2015-12-10 05:05:49 EST
*** Bug 1290346 has been marked as a duplicate of this bug. ***
Comment 7 ilmostro7 2015-12-10 05:16:03 EST
Yup...sucks big time

Scriptlet output:
   1 Could not load host key: /etc/ssh/ssh_host_dsa_key
   2 warning: file /lib/modules/3.10.0-229.14.1.el7.x86_64/modules.softdep: remove failed: No such file or directory
   3 warning: file /lib/modules/3.10.0-229.14.1.el7.x86_64/modules.devname: remove failed: No such file or directory
   4 IPA server upgrade failed: Inspect /var/log/ipaupgrade.log and run command ipa-server-upgrade manually.
   5 ("Unable to execute IPA upgrade: data are in newer version than IPA (data version '4.2.0-15.el7', IPA version '4.2.0-15.el7_2.3')", 1)
Comment 8 ilmostro7 2015-12-10 05:18:23 EST
Not sure why the naming format; perhaps specfile got botched? Maybe it should be version 4.2.3.el7 instead of 4.2.0-15.el7_2.3?
Comment 9 Martin Bašti 2015-12-10 05:24:12 EST
(In reply to ilmostro7 from comment #8)
> Not sure why the naming format; perhaps specfile got botched? Maybe it
> should be version 4.2.3.el7 instead of 4.2.0-15.el7_2.3?

This is bug in checking version method, 4.2.0-15.el7_2.3 version is okay.
Comment 12 Petr Vobornik 2016-01-08 08:32:59 EST
the upstream patch causes https://fedorahosted.org/freeipa/ticket/5572 Different approach needs to be used.
Comment 13 Jan Cholasta 2016-01-11 12:22:20 EST
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5572
Comment 18 Nikhil Dehadrai 2016-08-08 06:28:18 EDT
IPA server version: ipa-server-4.4.0-3.el7.x86_64

Verified the bug on the basis of following steps:
1. Verified that no error message is observed during upgrade of IPA server.
2. Verified the bug for upgrade paths:
   a) 7.2(GA) to 7.3
   b) 7.2.z to 7.3 (In my case upgrade from 7.2up6)

 Thus on the basis of above observations marking the status of bug to "VERIFIED".
Comment 23 errata-xmlrpc 2016-11-04 01:42:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.