This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 129057 - I am unable to boot in single mode with initrd made with new mkinitrd
I am unable to boot in single mode with initrd made with new mkinitrd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
: 129099 (view as bug list)
Depends On:
Blocks: FC3Target FC3BugWeekQA
  Show dependency treegraph
 
Reported: 2004-08-03 12:35 EDT by Knut J BJuland
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 23:27:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2004-08-03 12:35:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
Sinve I upgrade mkinitrd I have been unable to boot in singe mode by
adding singel in boot. I use lates kernel-2.6.7-1.503.

Version-Release number of selected component (if applicable):
mkinitrd-4.0.0-1

How reproducible:
Always

Steps to Reproduce:
1.boot with grub add singel behind kernel
2.
3.
    

Actual Results:  what the pc boot into mode 5

Expected Results:  I should be able to boot into singel mode at leaste
initrd built with previous mkinitrd enable me to do it.

Additional info:

single mode booting is an easy way to compile nvidia driver before
swithing to mode 5.
Comment 1 Jeremy Katz 2004-08-03 17:19:04 EDT
If you boot with init=/sbin/init S, does it work?  I'm guessing so.

Unfortunately, I'm not really clear on how this is supposed to work
when you're doing an initramfs -- passing all of the arguments to init
is clearly wrong, yet there's no way to figure out which ones are
valid to pass to init (as the kernel will make use of some of them). 
cc'ing some kernel guys to argue it out :)
Comment 2 Knut J BJuland 2004-08-04 05:52:59 EDT
Passing init=/sbin/init S works with initramfs initrd.img.  Since I
compiled XFS into the kernel I am able to do without initrd.image.
Comment 3 Bill Nottingham 2004-08-04 11:41:22 EDT
*** Bug 129099 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2004-08-04 12:58:06 EDT
Fixed in 4.0.1
Comment 5 Jef Spaleta 2004-09-27 23:27:33 EDT
Confirmed that mkinitrd-4.1.12-1 allows me to boot using the word
"single" as a boottime kernel parameter with kernel-2.6.8-1.541

Closing.

-jef

Note You need to log in before you can comment on or make changes to this bug.