Bug 1290583 - remove repositories sub tab
remove repositories sub tab
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Jozef Zigmund
Niyaz Akhtar Ansari
ui
:
Depends On:
Blocks: 1290805
  Show dependency treegraph
 
Reported: 2015-12-10 16:09 EST by Dave Johnson
Modified: 2016-06-29 11:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1290805 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:19:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Johnson 2015-12-10 16:09:02 EST
Description of problem:
==========================
Repositories are no longer usable with the removal of the external smart proxy, we need to remove the tab (under infrastructure tab) until we come up with a solution to that.
Comment 3 CFME Bot 2016-04-11 11:56:15 EDT
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/1afae2dc3a67f048ae813d777856fae76e5a0a9e

commit 1afae2dc3a67f048ae813d777856fae76e5a0a9e
Author:     Jozef Zigmund <jzigmund@redhat.com>
AuthorDate: Mon Feb 8 20:09:52 2016 +0100
Commit:     Jozef Zigmund <jzigmund@redhat.com>
CommitDate: Mon Apr 11 15:48:20 2016 +0200

    Removal of the files related to Repository
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290583

 app/assets/images/100/repository.png               | Bin 1975 -> 0 bytes
 .../repository/repository_form_controller.js       |  58 ---
 .../directives/repository/valid_unc_path.js        |  46 ---
 app/controllers/repository_controller.rb           | 387 ---------------------
 .../toolbar/repositories_center.rb                 |  73 ----
 .../toolbar/repository_center.rb                   |  52 ---
 app/helpers/repository_helper.rb                   |   3 -
 app/helpers/repository_helper/textual_summary.rb   |  37 --
 app/models/repository.rb                           | 133 -------
 app/views/layouts/listnav/_repository.html.haml    |  26 --
 app/views/layouts/quadicon/_repository.html.haml   |  20 --
 app/views/repository/_form.html.haml               |  53 ---
 app/views/repository/_main.html.haml               |   5 -
 app/views/repository/edit.html.haml                |   1 -
 app/views/repository/new.html.haml                 |   1 -
 app/views/repository/show.html.haml                |  10 -
 app/views/repository/show_list.html.haml           |   2 -
 product/views/Repository.yaml                      |  75 ----
 spec/controllers/repository_controller_spec.rb     |  53 ---
 spec/factories/repository.rb                       |   6 -
 .../repository/repository_form_controller_spec.js  |  72 ----
 .../directives/repository/valid_unc_path_spec.js   |  35 --
 spec/models/repository_spec.rb                     |  48 ---
 spec/routing/repository_routing_spec.rb            |  57 ---
 24 files changed, 1253 deletions(-)
 delete mode 100644 app/assets/images/100/repository.png
 delete mode 100644 app/assets/javascripts/controllers/repository/repository_form_controller.js
 delete mode 100644 app/assets/javascripts/directives/repository/valid_unc_path.js
 delete mode 100644 app/controllers/repository_controller.rb
 delete mode 100644 app/helpers/application_helper/toolbar/repositories_center.rb
 delete mode 100644 app/helpers/application_helper/toolbar/repository_center.rb
 delete mode 100644 app/helpers/repository_helper.rb
 delete mode 100644 app/helpers/repository_helper/textual_summary.rb
 delete mode 100644 app/models/repository.rb
 delete mode 100644 app/views/layouts/listnav/_repository.html.haml
 delete mode 100644 app/views/layouts/quadicon/_repository.html.haml
 delete mode 100644 app/views/repository/_form.html.haml
 delete mode 100644 app/views/repository/_main.html.haml
 delete mode 100644 app/views/repository/edit.html.haml
 delete mode 100644 app/views/repository/new.html.haml
 delete mode 100644 app/views/repository/show.html.haml
 delete mode 100644 app/views/repository/show_list.html.haml
 delete mode 100755 product/views/Repository.yaml
 delete mode 100644 spec/controllers/repository_controller_spec.rb
 delete mode 100644 spec/factories/repository.rb
 delete mode 100644 spec/javascripts/controllers/repository/repository_form_controller_spec.js
 delete mode 100644 spec/javascripts/directives/repository/valid_unc_path_spec.js
 delete mode 100644 spec/models/repository_spec.rb
 delete mode 100644 spec/routing/repository_routing_spec.rb
Comment 4 CFME Bot 2016-04-22 11:21:48 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=651082e898b64a13ed767e3af169ff0b23198bcb

commit 651082e898b64a13ed767e3af169ff0b23198bcb
Author:     Jozef Zigmund <jzigmund@redhat.com>
AuthorDate: Mon Feb 8 20:09:52 2016 +0100
Commit:     Jozef Zigmund <jzigmund@redhat.com>
CommitDate: Mon Apr 18 17:35:00 2016 +0200

    Removal of the files related to Repository
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290583

 .../repository/repository_form_controller.js       |  58 ----
 .../directives/repository/valid_unc_path.js        |  46 ---
 app/controllers/repository_controller.rb           | 361 ---------------------
 app/helpers/repository_helper.rb                   |   3 -
 app/helpers/repository_helper/textual_summary.rb   |  37 ---
 app/models/repository.rb                           | 133 --------
 app/views/layouts/listnav/_repository.html.haml    |  32 --
 app/views/layouts/quadicon/_repository.html.haml   |  20 --
 app/views/repository/_form.html.haml               |  53 ---
 app/views/repository/_main.html.haml               |   5 -
 app/views/repository/edit.html.haml                |   1 -
 app/views/repository/new.html.haml                 |   1 -
 app/views/repository/show.html.haml                |  10 -
 app/views/repository/show_list.html.haml           |   2 -
 product/views/Repository.yaml                      |  75 -----
 spec/controllers/repository_controller_spec.rb     |  55 ----
 spec/factories/repository.rb                       |   6 -
 .../repository/repository_form_controller_spec.js  |  72 ----
 .../directives/repository/valid_unc_path_spec.js   |  35 --
 spec/models/repository_spec.rb                     |  50 ---
 spec/routing/repository_routing_spec.rb            |  58 ----
 21 files changed, 1113 deletions(-)
 delete mode 100644 app/assets/javascripts/controllers/repository/repository_form_controller.js
 delete mode 100644 app/assets/javascripts/directives/repository/valid_unc_path.js
 delete mode 100644 app/controllers/repository_controller.rb
 delete mode 100644 app/helpers/repository_helper.rb
 delete mode 100644 app/helpers/repository_helper/textual_summary.rb
 delete mode 100644 app/models/repository.rb
 delete mode 100644 app/views/layouts/listnav/_repository.html.haml
 delete mode 100644 app/views/layouts/quadicon/_repository.html.haml
 delete mode 100644 app/views/repository/_form.html.haml
 delete mode 100644 app/views/repository/_main.html.haml
 delete mode 100644 app/views/repository/edit.html.haml
 delete mode 100644 app/views/repository/new.html.haml
 delete mode 100644 app/views/repository/show.html.haml
 delete mode 100644 app/views/repository/show_list.html.haml
 delete mode 100755 product/views/Repository.yaml
 delete mode 100644 spec/controllers/repository_controller_spec.rb
 delete mode 100644 spec/factories/repository.rb
 delete mode 100644 spec/javascripts/controllers/repository/repository_form_controller_spec.js
 delete mode 100644 spec/javascripts/directives/repository/valid_unc_path_spec.js
 delete mode 100644 spec/models/repository_spec.rb
 delete mode 100644 spec/routing/repository_routing_spec.rb
Comment 5 Niyaz Akhtar Ansari 2016-05-04 01:28:21 EDT
Subtab Repositories has been removed.

Verified in 5.6.0.5-beta2.4.20160503153816_1fb554f
Comment 7 errata-xmlrpc 2016-06-29 11:19:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.