Bug 1290805 - remove repositories sub tab
remove repositories sub tab
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.4
Assigned To: Jozef Zigmund
Niyaz Akhtar Ansari
: ZStream
Depends On: 1290583
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-11 09:07 EST by John Prause
Modified: 2016-05-31 09:40 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.5.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290583
Environment:
Last Closed: 2016-05-31 09:40:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2016-04-22 11:21:52 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c709cf57488e185890c8c1806221cc5f74ee8f09

commit c709cf57488e185890c8c1806221cc5f74ee8f09
Merge: 40ca0bf 1986ac9
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Apr 22 10:55:43 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Apr 22 10:55:43 2016 -0400

    Merge branch 'bz1290805-remove_repositories_subtab' into '5.5.z'
    
    Removing Repositories sub tab
    
    Cherry-picked commits that removing Repositories subtab(whole resource, code references).
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1290805
    
    See merge request !899

 app/assets/javascripts/application.js              |  39 +--
 .../controllers/container_dashboard/util.js        |   1 +
 .../util/dashboard-util-module.js                  |   1 -
 .../repository/repository_form_controller.js       |  58 ----
 .../directives/repository/valid_unc_path.js        |  46 ---
 app/controllers/application_controller.rb          |   4 +-
 app/controllers/repository_controller.rb           | 361 ---------------------
 app/helpers/application_helper.rb                  |  12 +-
 app/helpers/application_helper/toolbar_chooser.rb  |   2 +-
 app/helpers/repository_helper.rb                   |   3 -
 app/helpers/repository_helper/textual_summary.rb   |  37 ---
 app/helpers/ui_constants.rb                        |   1 -
 .../vmware/infra_manager/refresh_parser.rb         |   2 +-
 app/models/miq_expression.rb                       |   3 -
 app/models/miq_report/generator/html.rb            |   2 +-
 app/models/rbac.rb                                 |   1 -
 app/models/repository.rb                           | 133 --------
 app/models/vm_or_template.rb                       |  34 +-
 app/presenters/menu/default_menu.rb                |   1 -
 app/views/configuration/_ui_2.html.haml            |   8 +-
 app/views/layouts/listnav/_repository.html.haml    |  32 --
 app/views/layouts/quadicon/_repository.html.haml   |  20 --
 app/views/repository/_form.html.haml               |  53 ---
 app/views/repository/_main.html.haml               |   5 -
 app/views/repository/edit.html.haml                |   1 -
 app/views/repository/new.html.haml                 |   1 -
 app/views/repository/show.html.haml                |  10 -
 app/views/repository/show_list.html.haml           |   2 -
 config/routes.rb                                   |  33 --
 db/fixtures/miq_product_features.yml               |  54 ---
 db/fixtures/miq_shortcuts.yml                      |   5 -
 db/fixtures/miq_user_roles.yml                     |  25 --
 product/alerts/rss/newest_vms.yml                  |   3 -
 product/toolbars/repositories_center_tb.yaml       |  66 ----
 product/toolbars/repository_center_tb.yaml         |  45 ---
 product/views/Repository.yaml                      |  75 -----
 public/images/icons/new/repository.png             | Bin 3275 -> 0 bytes
 spa_ui/self_service/package.json                   |   1 +
 spec/controllers/repository_controller_spec.rb     |  55 ----
 spec/factories/repository.rb                       |   6 -
 .../repository/repository_form_controller_spec.js  |  72 ----
 .../directives/repository/valid_unc_path_spec.js   |  35 --
 spec/models/async_delete_mixin_spec.rb             |  16 -
 spec/models/miq_product_feature_spec.rb            |   2 +-
 spec/models/repository_spec.rb                     |  50 ---
 spec/models/rss_feed/data/newest_vms.yml           |   3 -
 spec/presenters/menu/default_menu_spec.rb          |  12 +-
 spec/routing/repository_routing_spec.rb            |  58 ----
 48 files changed, 54 insertions(+), 1435 deletions(-)
Comment 5 Niyaz Akhtar Ansari 2016-05-03 07:08:04 EDT
Subtab Repositories has been removed.

Verified in 5.5.4.0.20160426160942_629f93b
Comment 7 errata-xmlrpc 2016-05-31 09:40:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1101

Note You need to log in before you can comment on or make changes to this bug.