Bug 1290677 - tiering: T files getting created , even after disk quota exceeds
tiering: T files getting created , even after disk quota exceeds
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: ZStream
Depends On: 1285797
Blocks: 1260783 1295359
  Show dependency treegraph
 
Reported: 2015-12-11 01:05 EST by Mohammed Rafi KC
Modified: 2016-06-16 09:50 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285797
: 1295359 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:50:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-11 01:39:42 EST
REVIEW: http://review.gluster.org/12948 (dht:delete the linkfile if data file creation fails) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-12-12 02:32:10 EST
REVIEW: http://review.gluster.org/12948 (dht:delete the linkfile if data file creation fails) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2015-12-21 10:16:31 EST
REVIEW: http://review.gluster.org/12948 (dht:delete the linkfile if data file creation fails) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 4 Vijay Bellur 2015-12-21 15:42:10 EST
REVIEW: http://review.gluster.org/12948 (dht:delete the linkfile if data file creation fails) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 5 Vijay Bellur 2015-12-22 01:52:44 EST
REVIEW: http://review.gluster.org/12948 (dht:delete the linkfile if data file creation fails) posted (#6) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 6 Vijay Bellur 2015-12-22 02:05:23 EST
REVIEW: http://review.gluster.org/12948 (dht:delete the linkfile if data file creation fails) posted (#7) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 7 Vijay Bellur 2015-12-22 03:01:04 EST
REVIEW: http://review.gluster.org/12948 (tier:delete the linkfile if data file creation fails) posted (#8) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 8 Vijay Bellur 2015-12-22 08:12:00 EST
COMMIT: http://review.gluster.org/12948 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit d3fd13688f850e58bfa517a4c2d17e8fa4343dcf
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Dec 10 20:13:22 2015 +0530

    tier:delete the linkfile if data file creation fails
    
    If we are creating data file in a hot subvolume
    then we will create a linkfile in cold subvolume.
    Linkfile creation happens first. If linkfile creation
    was successful and data file creation failed, then
    linkfile in cold subvolume will become stale.
    
    This patch will delete the linkfile as well, if data
    file creation fails.
    
    Also this code duplicates dht_create to make tier_create
    
    Change-Id: I377a90dad47f288e9576c7323b23cf694a91a7a3
    BUG: 1290677
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12948
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 9 Vijay Bellur 2015-12-28 09:09:42 EST
REVIEW: http://review.gluster.org/13102 (tier/create: Dynamically allocate gfid memory) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 10 Vijay Bellur 2016-01-02 09:48:00 EST
REVIEW: http://review.gluster.org/13129 (tier/create: add TIER_LINKFILE_GFID to ignorable xattr) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 11 Vijay Bellur 2016-01-02 13:12:10 EST
REVIEW: http://review.gluster.org/13130 (tier/create: store TIER_LINKFILE_GFID in xattr dictionary) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 12 Mohammed Rafi KC 2016-01-04 04:06:28 EST
One more patch need to be merged as part of the bug
Comment 13 Vijay Bellur 2016-01-04 07:29:11 EST
REVIEW: http://review.gluster.org/13130 (tier/create: store TIER_LINKFILE_GFID in xattr dictionary) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 14 Vijay Bellur 2016-01-04 13:24:22 EST
REVIEW: http://review.gluster.org/13130 (tier/create: store TIER_LINKFILE_GFID in xattr dictionary) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 15 Vijay Bellur 2016-01-05 07:42:59 EST
COMMIT: http://review.gluster.org/13130 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 45b1bf53da028b92ea7fc3f21a53f2a3cb0d8b0c
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Sat Jan 2 23:34:54 2016 +0530

    tier/create: store TIER_LINKFILE_GFID in xattr dictionary
    
    In tier_create, a new key TIER_LINKFILE_GFID was introduced to
    avoid a race in stale linkfile deletion. Storing this key in
    xattr dictionary instead of using local->params dictionary.
    
    Because local->params dictionary was also used to create the file
    before stale linkfile deletion, that leads posix_create to fail,
    trying to set the added key as extended attributes
    
    Change-Id: I24fecb62b47bee65a1e86103925a67d13304c5df
    BUG: 1290677
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13130
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 16 Niels de Vos 2016-06-16 09:50:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.