Bug 1295359 - tiering: T files getting created , even after disk quota exceeds
tiering: T files getting created , even after disk quota exceeds
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.7
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: ZStream
Depends On: 1285797 1290677
Blocks: 1260783 glusterfs-3.7.9
  Show dependency treegraph
 
Reported: 2016-01-04 04:05 EST by Mohammed Rafi KC
Modified: 2016-04-19 03:23 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290677
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-04 04:10:49 EST
REVIEW: http://review.gluster.org/13162 (tier/create: Dynamically allocate gfid memory) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2016-01-04 04:20:07 EST
REVIEW: http://review.gluster.org/13162 (tier/create: Dynamically allocate gfid memory) posted (#2) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2016-01-04 04:20:11 EST
REVIEW: http://review.gluster.org/13161 (tier:delete the linkfile if data file creation fails) posted (#2) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 4 Vijay Bellur 2016-02-10 00:48:58 EST
REVIEW: http://review.gluster.org/13162 (tier/create: Dynamically allocate gfid memory) posted (#3) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 5 Vijay Bellur 2016-02-10 00:49:20 EST
REVIEW: http://review.gluster.org/13161 (tier:delete the linkfile if data file creation fails) posted (#3) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 6 Vijay Bellur 2016-02-10 00:49:49 EST
REVIEW: http://review.gluster.org/13410 (tier/create: store TIER_LINKFILE_GFID in xattr dictionary) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)
Comment 7 Vijay Bellur 2016-02-22 09:53:13 EST
COMMIT: http://review.gluster.org/13161 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 40902503da073bb106ba0eef7788692f0cfcfc20
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Dec 10 20:13:22 2015 +0530

    tier:delete the linkfile if data file creation fails
    
    If we are creating data file in a hot subvolume
    then we will create a linkfile in cold subvolume.
    Linkfile creation happens first. If linkfile creation
    was successful and data file creation failed, then
    linkfile in cold subvolume will become stale
    
    This patch will delete the linkfile as well, if data
    file creation fails
    
    Also this code duplicates dht_create to make tier_create
    
    backport of>
    >Change-Id: I377a90dad47f288e9576c7323b23cf694a91a7a3
    >BUG: 1290677
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/12948
    >Reviewed-by: N Balachandran <nbalacha@redhat.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: I3689e8ee387fb6731b4b3a7fe8f8190143482eaa
    BUG: 1295359
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13161
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 8 Vijay Bellur 2016-02-22 09:53:55 EST
COMMIT: http://review.gluster.org/13162 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 64b964187e413879269dd7e5ede44c16fc6efc5e
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Dec 28 19:31:36 2015 +0530

    tier/create: Dynamically allocate gfid memory
    
    Currently we are storing the memory as a static pointer.
    There is a chance to go that variable in out of scope.
    So we should allocate in Dynamic way.
    
    Backport of>
    >Change-Id: I096876deb8055ac3a44681599591a0a032bc0c24
    >BUG: 1290677
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/13102
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: N Balachandran <nbalacha@redhat.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: Ibc5cde24db4846ef3152366cdaca81dd1d0e7b21
    BUG: 1295359
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13162
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 9 Vijay Bellur 2016-02-22 09:54:22 EST
COMMIT: http://review.gluster.org/13410 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 235237e5a968261df3d34f969d909550a6b74b77
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Sat Jan 2 23:34:54 2016 +0530

    tier/create: store TIER_LINKFILE_GFID in xattr dictionary
    
    In tier_create, a new key TIER_LINKFILE_GFID was introduced to
    avoid a race in stale linkfile deletion. Storing this key in
    xattr dictionary instead of using local->params dictionary.
    
    Because local->params dictionary was also used to create the file
    before stale linkfile deletion, that leads posix_create to fail,
    trying to set the added key as extended attributes
    
    Back port of>
    >Change-Id: I24fecb62b47bee65a1e86103925a67d13304c5df
    >BUG: 1290677
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/13130
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: N Balachandran <nbalacha@redhat.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: I301c159ee51c77d3876e30f216d0375d761eb91e
    BUG: 1295359
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13410
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 10 Kaushal 2016-04-19 03:23:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 11 Kaushal 2016-04-19 03:23:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 12 Kaushal 2016-04-19 03:23:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.