Bug 1290744 - The RHEL 7 SystemD generated machine-id is slightly different than the machine-id generated by the Insights client, it should be handled properly in CFME.
The RHEL 7 SystemD generated machine-id is slightly different than the machin...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Red Hat Access (Show other bugs)
5.5.0
x86_64 Linux
high Severity high
: GA
: 5.6.0
Assigned To: Lindani Phiri
Satyajit Bulage
: ZStream
Depends On:
Blocks: 1297880
  Show dependency treegraph
 
Reported: 2015-12-11 05:16 EST by Anisha Narang
Modified: 2016-07-27 02:33 EDT (History)
12 users (show)

See Also:
Fixed In Version: 5.6.0.0 (rubygem-redhat_access_cfme-1.0.1-1)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1297880 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:19:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anisha Narang 2015-12-11 05:16:26 EST
Description of problem:
When we register a RHEL7 machine to Insights service, it does not show up under RHI> Systems in CFME.
For a rhel6 machine, that works well.
There is a difference in the machine-id generation by RHEL6 and RHEL7 and we require to add code to handle that properly in CFME for rhel7.

Fore reference:
RHEL7:
[root@dhcp10 ~]# cat /etc/machine-id
f37407eae3e44d33abcca9391fcb843f
[root@dhcp10 ~]# cat /etc/redhat-access-insights/machine-id
f37407eae3e44d33abcca9391fcb843f

RHEL6:
[root@cfmetestrhel6 ~]# cat /etc/redhat-access-insights/machine-id
f957cc10-ed72-4b70-a409-072a0d93fb59

You can see the difference above in the machine-id format for rhel6 and rhel7.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Go to CFME, and make proper configurations with Red Hat Updates and VMs.
2. Register a RHEL 7 machine to Insights service.
3. CFME > Infrastructure > Virtual Machines> Select the registered VM and run 'Perfrom Smart State Analysis'
4. Go to Red Hat Insights > Systems.
You shall find the registered system under the list of systems, but rhel7 systems do not appear currently.


Actual results:
The rhel7 systems do not appear listed under RHI> Systems in CFME

Expected results:
RHEL 7 systems should appear in the list under RHI> Systems in CFME after being registered to Insights service.

Additional info:
Comment 2 Vadim Rutkovsky 2016-02-15 09:14:18 EST
Workaround: run 'redhat-access-insights --force-reregister'
Comment 3 Lindani Phiri 2016-03-08 10:39:20 EST
Fixed.
Comment 4 ldomb 2016-03-23 09:05:05 EDT
This does not seem fixed it for me. 

2. My EVM is registered via subscription manager (not satellite6) and has the status  Subscribed / Last Message Registered

3. The default profile for the smart state analysis has /etc/redhat-access-insights/machine-id -> true

4. Provider refresh for RHEV so that it discovers the 2 vm's

5. I yum removed the redhat-access-insights package and rm -rf /etc/redhat/access-insights on the vm's

6. I installed redhat-access-insights on the RHEL7 vm's and registered with redhat-access-insights --force-reregister

(the vm's are registered with the same rhn user as the cfme appliance)

7. The ID of look like this 1d1d6d48-1250-4b1e-8b20-0362140ee4b3 and abdab4e5-b992-4b7e-92bb-6f9ce8e549f3 (looks like the right format to me)

8. Run a smart state analysis on the machine successfully and see that the file was indexed.

9. Click on the Insight tab in CFME. still no data
Comment 6 Lindani Phiri 2016-03-23 20:47:05 EDT
The issue seen by Laurent is unrelated to this bug, even though the symptoms are similar.  A change in the external Insights API was made that broke backwards compatibility.  Once the API is fixed Laurent's issue should disappear without any changes to the CFME appliance.
Comment 7 Satyajit Bulage 2016-05-27 05:59:15 EDT
Both rhel6 and rhel7 machines are appearing in RHI> Systems tab.
machine-id for both the systems are in the same format as follows:

For rhel6 machine:
cat /etc/redhat-access-insights/machine-id
9492cda7-6427-4dfb-8f29-6caa41fcfa87

For rhel7 machine:
cat /etc/redhat-access-insights/machine-id
9db21438-92d9-4ecf-a22a-e7b4674fe7d6


Verified Version:-5.6.0.8-rc1.20160524155303_f2a5a50
Comment 9 errata-xmlrpc 2016-06-29 11:19:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.