Bug 1290766 - [RFE] quota: enhance quota enable and disable process
[RFE] quota: enhance quota enable and disable process
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manikandan
: FutureFeature
Depends On:
Blocks: 1312199 glusterfs-3.8.0
  Show dependency treegraph
 
Reported: 2015-12-11 07:09 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:50 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1312199 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:50:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-12-11 07:09:24 EST
Currently quota crawl is done from the single mount point,
this is very slow process if there are huge number of files exists
in the volume
    
This RFE will now spawn crawl process for each brick in the
volume, and  files are looked in parallel independently for each
brick. This improves the speed of crawling process for
entire files-system
Comment 1 Vijay Bellur 2015-12-11 07:11:33 EST
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-12-11 07:22:54 EST
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2015-12-11 07:28:12 EST
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2015-12-15 00:47:25 EST
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Vijay Bellur 2015-12-15 01:36:11 EST
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 6 Vijay Bellur 2016-01-19 06:26:50 EST
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 7 Vijay Bellur 2016-02-02 03:18:16 EST
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#7) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 8 Vijay Bellur 2016-03-04 07:40:01 EST
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#8) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 9 Vijay Bellur 2016-03-07 02:02:40 EST
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#9) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 10 Vijay Bellur 2016-04-02 00:33:54 EDT
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#10) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 11 Vijay Bellur 2016-04-06 08:17:39 EDT
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#11) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 12 Vijay Bellur 2016-04-12 03:56:33 EDT
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#12) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 13 Vijay Bellur 2016-04-12 05:13:32 EDT
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#13) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 14 Vijay Bellur 2016-04-12 05:47:42 EDT
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#14) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 15 Vijay Bellur 2016-04-12 10:58:44 EDT
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#15) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 16 Vijay Bellur 2016-04-29 02:46:52 EDT
REVIEW: http://review.gluster.org/12952 (quota/glusterd: enhance quota enable and disable process) posted (#16) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 17 Vijay Bellur 2016-04-29 06:11:38 EDT
COMMIT: http://review.gluster.org/12952 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit c2865e83d414e375443adac0791887c8adf444f2
Author: vmallika <vmallika@redhat.com>
Date:   Sat Apr 2 09:50:11 2016 +0530

    quota/glusterd: enhance quota enable and disable process
    
    Previously quota crawl was done from the single mount point,
    this is very slow process if there are huge number of files exists
    in the volume
    
    This RFE will now spawn crawl process for each brick in the
    volume, and  files are looked in parallel independently for each
    brick. This improves the speed of crawling process for
    entire files-system
    
    This patch also fixes below problem
    * Previously, mountdir was created under '/tmp'.
      If someone tries to cleanup '/tmp'/ directory
      then it is very dangerous that we loose volume data
      So create a mount point under /var/run/gluster/tmp
      instead
    
    * Previously, file-system crawl is performed from all the nodes,
      which is a redundant operation and performance will degrade
      The problem is fixed with this patch
    
    Change-Id: Icabedeb44182139ace9c8106793803122388cab8
    BUG: 1290766
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/12952
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Manikandan Selvaganesh <mselvaga@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 20 Niels de Vos 2016-06-16 09:50:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.