Bug 1290784 - [abrt] java-1.8.0-openjdk-headless: gdk_event_source_prepare(): java killed by SIGTRAP
[abrt] java-1.8.0-openjdk-headless: gdk_event_source_prepare(): java killed b...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ff9a2fddd894922a0dd888df904...
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-12-11 08:02 EST by Christian Stadelmann
Modified: 2016-09-28 16:28 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-28 16:28:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.78 KB, text/plain)
2015-12-11 08:02 EST, Christian Stadelmann
no flags Details
File: core_backtrace (112.92 KB, text/plain)
2015-12-11 08:02 EST, Christian Stadelmann
no flags Details
File: dso_list (25.21 KB, text/plain)
2015-12-11 08:02 EST, Christian Stadelmann
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-11 08:02 EST, Christian Stadelmann
no flags Details
File: maps (89.39 KB, text/plain)
2015-12-11 08:02 EST, Christian Stadelmann
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-11 08:02 EST, Christian Stadelmann
no flags Details
File: open_fds (21.54 KB, text/plain)
2015-12-11 08:02 EST, Christian Stadelmann
no flags Details
File: proc_pid_status (1018 bytes, text/plain)
2015-12-11 08:02 EST, Christian Stadelmann
no flags Details
a full backtrace on java at "display_protocol_error" (499.22 KB, text/plain)
2016-09-06 15:23 EDT, Christian Stadelmann
no flags Details
eclipse log file [workspace]/.metadata/.log (69.54 KB, text/plain)
2016-09-26 14:49 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-12-11 08:02:06 EST
Description of problem:
I ran eclipse in a Gnome+Wayland session, so it was running with SWT+Gtk3+Wayland backend. When right-clicking on one of the perspectives, eclipse crashes.

Version-Release number of selected component:
java-1.8.0-openjdk-headless-1.8.0.65-4.b17.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/java -Xms512m -Xmx4096m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -server -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.100.v20151208-0700.jar -os linux -ws gtk -arch x86_64 -showsplash /usr/lib64/eclipse//plugins/org.eclipse.platform_4.5.1.v20151208-0700/splash.bmp -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.300.v20151208-0700/eclipse_1613.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.100.v20151208-0700.jar -protect master --launcher.appendVmargs -exitdata 1528005 -vm /usr/bin/java -vmargs -Xms512m -Xmx4096m -Dorg.eclipse.swt.browser.UseWebKitGTK=true -Dhelp.lucene.tokenizer=standard -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/eclipse/tycho/core/osgitools/EquinoxResolver,newState -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dp2.fragments=/usr/share/eclipse/droplets,/usr/lib64/eclipse/droplets -Declipse.p2.skipMovedInstallDetection=true -server -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.3.100.v20151208-0700.jar
crash_function: gdk_event_source_prepare
executable:     /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.65-4.b17.fc23.x86_64/jre/bin/java
kernel:         4.2.6-301.fc23.x86_64
runlevel:       N 5
type:           CCpp

Truncated backtrace:
Thread no. 0 (4 frames)
 #3 gdk_event_source_prepare at gdkeventsource.c:55
 #4 g_main_context_prepare at gmain.c:3442
 #6 g_main_context_iteration at gmain.c:3901
 #7 Java_org_eclipse_swt_internal_gtk_OS__1g_1main_1context_1iteration at os.c:3448
Comment 1 Christian Stadelmann 2015-12-11 08:02:13 EST
Created attachment 1104641 [details]
File: backtrace
Comment 2 Christian Stadelmann 2015-12-11 08:02:16 EST
Created attachment 1104642 [details]
File: core_backtrace
Comment 3 Christian Stadelmann 2015-12-11 08:02:17 EST
Created attachment 1104643 [details]
File: dso_list
Comment 4 Christian Stadelmann 2015-12-11 08:02:19 EST
Created attachment 1104644 [details]
File: limits
Comment 5 Christian Stadelmann 2015-12-11 08:02:21 EST
Created attachment 1104645 [details]
File: maps
Comment 6 Christian Stadelmann 2015-12-11 08:02:23 EST
Created attachment 1104646 [details]
File: namespaces
Comment 7 Christian Stadelmann 2015-12-11 08:02:25 EST
Created attachment 1104647 [details]
File: open_fds
Comment 8 Christian Stadelmann 2015-12-11 08:02:27 EST
Created attachment 1104648 [details]
File: proc_pid_status
Comment 9 Christian Stadelmann 2015-12-11 08:20:35 EST
Probably an issue in Eclipse or Gtk3.

Software versions:
eclipse-platform-4.5.1-6.fc23.x86_64
eclipse-swt-4.5.1-6.fc23.x86_64
gtk3-3.18.6-1.fc23.x86_64
glib2-2.46.2-1.fc23.x86_64
xorg-x11-server-Xwayland-1.18.0-2.fc23.x86_64
Comment 10 Kamil Páral 2015-12-15 04:46:40 EST
Hi Christian, can you reproduce this reliably? Does the same crash occur when running under X11 or not? Thanks.
Comment 11 Christian Stadelmann 2015-12-15 12:44:40 EST
This crash does not happen when running under X11 (or under XWayland with GDK_BACKEND=x11 set), only on wayland (with wayland backend for Gtk+ 3.x). With X11 backend I am running into this issue instead: https://bugzilla.redhat.com/show_bug.cgi?id=1290791

Yes, I can reproduce this reliably. Steps to reproduce:
1. open eclipse with gtk3 in a wayland session. Gtk3 should choose wayland as its backend by default. Select a workspace if required
2. open any perspective
3. right-click on the perspective (right top corner of eclipse main window)

What happens:
Instant crash.

Note: you might have trouble right-clicking on the perspective button due to https://bugzilla.redhat.com/show_bug.cgi?id=1255007 . I have to click ~20…50 pixels above the button to hit it.
Comment 12 Christian Stadelmann 2016-05-06 12:31:48 EDT
Still present with eclipse-swt-4.6.0-0.5.git201604261105.fc24.x86_64 on Wayland. Same reproducer as in comment #11.
Comment 13 Christian Stadelmann 2016-09-01 07:58:08 EDT
This bug now (in F25) triggers a crash in gnome-shell, see bug #1330510 and bug #1372311 for details.
Comment 14 Matthias Clasen 2016-09-06 14:36:48 EDT
If this is reproducible, you could try to break on display_protocol_error where the EPROTO originates.
Comment 15 Christian Stadelmann 2016-09-06 15:23 EDT
Created attachment 1198405 [details]
a full backtrace on java at "display_protocol_error"

(In reply to Christian Stadelmann from comment #13)
> This bug now (in F25) triggers a crash in gnome-shell, see bug #1330510 and
> bug #1372311 for details.

Same on F24 too.

(In reply to Matthias Clasen from comment #14)
> If this is reproducible, you could try to break on display_protocol_error
> where the EPROTO originates.

Yes, see attached logs. Steps I did:
0. run gdb from outside your gnome+wayland session, otherwise it will be killed when your session goes down.
1. start eclipse in a gnome+wayland session (and make sure it is running with wayland backend)
2. attach gdb to eclipse's child process named "java"
3. gdb: enable logging
4. gdb: disable handling of SIGSEGV because java is crazy and uses SIGSEGV for normal operation: `handle SIGSEGV nostop noprint`
5. gdb: `break display_protocol_error`
6. gdb: continue
7. eclipse: right-click on any perspective button
8. gdb: `bt` and `t a a bt full`, then continue to the next hit. In fact I ran these commands 3 times, the last one probably contains an error that the wayland compositor is gone.
9. quit gdb, recover your gnome wayland session
Comment 16 Christian Stadelmann 2016-09-26 14:49 EDT
Created attachment 1204930 [details]
eclipse log file [workspace]/.metadata/.log

When trying again to reproduce, eclipse crashes. This time with a more meaningful crasher reporting a stackoverflow. See attached logs for details.
Comment 17 Christian Stadelmann 2016-09-28 16:28:02 EDT
This issue is gone now on Fedora 25 with latest updates installed.

Note You need to log in before you can comment on or make changes to this bug.