Bug 1290833 - unable to check a checkbox in gtk3 app under KDE
unable to check a checkbox in gtk3 app under KDE
Status: CLOSED DUPLICATE of bug 1295043
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: oxygen-gtk3 (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
Depends On:
Blocks: 1297830 1313485
  Show dependency treegraph
 
Reported: 2015-12-11 10:20 EST by Michael Petlan
Modified: 2016-04-28 02:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-28 02:29:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Petlan 2015-12-11 10:20:33 EST
Description of problem:

When running a gtk3 application in KDE, it is not possible to check a checkbox in a settings dialog. When the checkbox is checked, it is immediately automatically unchecked again. No matter, whether I check it by clicking or by keyboard.

When the settings dialog is realtime (it immediately applies the option without requiring any "OK" or "Apply" button), the action is taken. But when it is a dialog with an "OK" button and checkbox (i.e. Remember Password checkbox on a Enter Password dialog), it can be never selected.


Version-Release number of selected component (if applicable):

gtk3-3.14.13-16.el7.x86_64
kdelibs-4.14.8-4.el7.x86_64
kde-runtime-4.10.5-8.el7.x86_64

... basically just RHEL 7.2 workstation with KDE


How reproducible:

Run any gtk3 based application under KDE, go for Settings and try to check a checkbox.

For example Empathy IM client, go for Empathy -> Preferences and try to check "Show offline contacts" checkbox.

It can be reproduced by other apps as well.

Actual results:

The checkbox cannot be checked.

Expected results:

The checkbox works.

Additional info:

When running a QT based application (i.e. Akregator), everything works as expected. Probably, the gtk based apps work well under GNOME.

Despite KDE is not the main DE on RHEL 7, it is still shipped and this bug spoils setting up of GTK based applications considerably.
Comment 2 Benjamin Otte 2016-04-27 19:20:39 EDT
I think this is a problem with the oxygen-gtk theme. The version we ship is too old for GTK 3.14 and needs to either be dropped or updated to 1.4.

Note that GTK dropped support for theming engines in GTK 3.16 (7.2 ships 3.14), so if RHEL7 updates GTK again, oxygen-gtk will stop working completely.
Comment 4 Michael Petlan 2016-04-27 20:00:29 EDT
(In reply to Benjamin Otte from comment #2)
> I think this is a problem with the oxygen-gtk theme. The version we ship is
> too old for GTK 3.14 and needs to either be dropped or updated to 1.4.
> 
> Note that GTK dropped support for theming engines in GTK 3.16 (7.2 ships
> 3.14), so if RHEL7 updates GTK again, oxygen-gtk will stop working
> completely.

Does that mean that after updating I won't be able to set dark theme for GTK based apps in KDE?
Comment 5 Jan Grulich 2016-04-28 02:29:23 EDT

*** This bug has been marked as a duplicate of bug 1295043 ***

Note You need to log in before you can comment on or make changes to this bug.