Bug 1295043 - Buttons not working as expected with GTK applications in KDE
Buttons not working as expected with GTK applications in KDE
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: oxygen-gtk3 (Show other bugs)
7.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Jan Grulich
Desktop QE
:
: 1290833 (view as bug list)
Depends On:
Blocks: 1203710 1297830 1313485
  Show dependency treegraph
 
Reported: 2016-01-01 05:21 EST by jigar
Modified: 2016-11-03 21:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes buttons issue in KDE (4.35 KB, patch)
2016-01-04 09:24 EST, jigar
no flags Details | Diff
Fix for radio buttons and virt-manager crash (2.49 KB, patch)
2016-01-27 03:37 EST, jigar
no flags Details | Diff

  None (edit)
Description jigar 2016-01-01 05:21:46 EST
Description of problem: On RHEL7.2 system when trying to create a new VM selection of option is not visible from the create new Virtual Machine window in KDE session. The same thing happens with evolution or any other GTK application in KDE session. The issue is specific to KDE environment. The same applications work fine in GNOME session.


Version-Release number of selected component (if applicable): gtk2-2.24.22-5


How reproducible: Always


Steps to Reproduce:

Test-1
1) Login into the system console as nonroot(admin/test/testadmin) or root user. 2) Open virt-manager and try to create a new VM.
3) Click on any option.

Test-2

1) Login into the system console as nonroot(admin/test/testadmin) or root user. 2) Open evolution and try to modify preferences.
3) Click on any option.

Actual results: The selection appears and then disappears in a blink.

Expected results: The buttons should show selection when clicked/selected.
Comment 4 jigar 2016-01-04 09:24 EST
Created attachment 1111498 [details]
Fixes buttons issue in KDE
Comment 6 Jan Grulich 2016-01-18 02:40:07 EST
Granting dev_ack+, patch is available.
Comment 7 jigar 2016-01-27 03:37 EST
Created attachment 1118705 [details]
Fix for radio buttons and virt-manager crash
Comment 8 Jan Grulich 2016-03-22 10:30:30 EDT
Fixed in oxygen-gtk3-1.1.4-4.el7.
Comment 11 Jan Grulich 2016-04-28 02:29:23 EDT
*** Bug 1290833 has been marked as a duplicate of this bug. ***
Comment 14 errata-xmlrpc 2016-11-03 21:28:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2236.html

Note You need to log in before you can comment on or make changes to this bug.