Bug 129096 - dhcp cannot be enabled for pseudo-devices/ethernet aliases
Summary: dhcp cannot be enabled for pseudo-devices/ethernet aliases
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
: 114145 (view as bug list)
Depends On:
Blocks: FC3Target 124022 127272
TreeView+ depends on / blocked
 
Reported: 2004-08-03 23:49 UTC by Jason Vas Dias
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 1.3.20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-03 12:00:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Vas Dias 2004-08-03 23:49:59 UTC
Description of problem:

With system-config-network GUI , users can create an 'Ethernet alias'
pseudo-device such as eth0:0 and enable dhcp on it; dhclient is,
however, unable to operate with such a device. 

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Select Devices->New and create an ethernet device from an existing
card.
2. A device such as 'eth0:0' is created.
3. You are prompted to configure the card with dhcp enabled by default 
  
Actual results:

If you specified 'activate' (ONBOOT=yes), or do an ifup for 
the device, then dhclient will write a message to the log:
   'Bind socket to interface: No such device'
and exit abnormally,
and the ifconfig fails with 
   'SIOCSIFFLAGS: Cannot assign requested address'.

The pseudo-device is not brought 'UP', can never be brought up,
and is quite useless until BOOTPROTO=none for it.

The design of dhclient is based on obtaining a PF_PACKET socket
bound to its interface; a PF_PACKET socket cannot be bound to
a pseudo-device. 

Expected results:

The user should not be allowed to enable DHCP on a pseudo interface.

Additional info:

There are numerous dhcp bugs on this issue, eg. bug 127272, 
bug 124022, to name a few. 

It is very confusing for users and a source of major annoyance.

dhclient cannot easily be changed to allow dhcp configuration of
pseudo-interfaces - it should be used to configure the real interface,
then the user would be able to create as many pseudo-interfaces with
static IPs as they like .

Comment 1 Jason Vas Dias 2004-08-04 21:30:46 UTC
*** Bug 114145 has been marked as a duplicate of this bug. ***

Comment 2 Jason Vas Dias 2004-08-04 21:37:55 UTC
*** Bug 114145 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.