Bug 129098 - gnome-theme-manager segfaulting
gnome-theme-manager segfaulting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-03 20:33 EDT by Jef Spaleta
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-25 19:47:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace i saved from the crash dialog for gnome-theme-manager (4.52 KB, text/plain)
2004-08-03 20:37 EDT, Jef Spaleta
no flags Details
stack trace with debuginfo installed (3.15 KB, text/plain)
2004-08-04 15:46 EDT, Thomas J. Baker
no flags Details
gtm backtrace (4.82 KB, text/plain)
2004-09-14 11:21 EDT, Thomas J. Baker
no flags Details
strace of gnome-theme-manager (1.39 MB, text/plain)
2005-05-08 15:42 EDT, Paolo Prandini
no flags Details

  None (edit)
Description Jef Spaleta 2004-08-03 20:33:30 EDT
Description of problem:
I am getting a consistent crash dialog with g-t-m.
No obvious errors being reported on stdout when i start it from a
terminal.

Version-Release number of selected component (if applicable):
control-center-2.6.1-4

How reproducible:
Everytime i attempt to start g-t-m

I'm as up2date with development tree as dependancies will allow.
Sorry i didnt try this preference gui before applying updates.


Additional info:
Attached is the backtrace reported to me in the bug-buddy crash
dialog.  Please advise if you need further information from me.

I'll report back if i find any other control-center executables that
have similar symptoms.
Comment 1 Jef Spaleta 2004-08-03 20:37:12 EDT
Created attachment 102411 [details]
backtrace i saved from the crash dialog for gnome-theme-manager
Comment 2 Thomas J. Baker 2004-08-04 15:46:08 EDT
Created attachment 102432 [details]
stack trace with debuginfo installed
Comment 3 Thomas J. Baker 2004-08-10 21:43:49 EDT
Appears fixed with an updated 8/10/2004 fc3t1+rawhide system.
Comment 4 Jef Spaleta 2004-08-10 22:44:13 EDT
Indeed i just checked my system. Seems to work fine now.
I'll close this as resolution rawhide. 

Comment 5 Jef Spaleta 2004-08-10 23:16:26 EDT
Crap!
I shouldn't have closed it without doing more testing. I'm going to
re-open this.  I have a consistent way to reproduce this on my system now.

If I don't have any local themes installed in .themes,  no problems.

If I install a theme, metacity or gtk2, g-t-m will crash out on me on
next restart. I've tried several gtk2 and metacity themes from
art.gnome.org and gnomelook.org, its not just one theme doing
something wrong.

I can avoid the g-t-m crash if I do  strace gnome-theme-manager.
Running under strace the crash dialog isn't triggered.

So please double check this situations:
1) install the metacity or gtk2 theme from art.gnome.org using the
install theme button inside g-t-m.  The MAO theme for metacity for
example from art.gnome.org.

2)restart g-t-m... i get a crash dialog at this point

3)strace g-t-m ... and it works as expected

4)delete the .themes directory and restart g-t-m.... works as expected.

-jef
Comment 6 Thomas J. Baker 2004-08-13 16:01:43 EDT
I installed the MAO metacity theme and it all works fine for me. After
doing the install using g-t-m, I had to quit and restart g-t-m for it
to see the new Window Border theme, but I'm able to switch to it,
switch away from it, etc without problems.
Comment 7 Jef Spaleta 2004-08-14 17:20:15 EDT
sigh, thats unnerving. Maybe its something particular about my user's
userspace settings.  I've tried deleting the .gconf* and the .gnome*
directories to see if this is some legacy userspace settings issue
that I'm seeing but its still there. The weird part is... if i start
g-t-m under strace it works every single time. I just don't know what
that means.. why would it work under strace but crash sometimes for me
outside of strace?

I'm going to backup this user's home directory, create a fresh home
directory and start over from there.

-jef 
Comment 8 Bryan W Clark 2004-09-14 01:42:31 EDT
- ping -

Jef are you still seeing this behavior?  I believe this issue has been
resolved for a couple releases of the package in rawhide.  Check if
you could please, I'm going to mark this as NEEDINFO until we hear back.
Comment 9 Jef Spaleta 2004-09-14 10:34:25 EDT
Sadly... im still seeing it.

Just tried to install the Office Metacity theme from art.gnome.org

1)downloaded the tarball to /tmp/MCity-Office_0.7.tar.bz2
2)opened g-t-m, no problem
3)used the install theme button and crawled the filesystem to the /tmp
directory and g-t-m allowed me to select the tarball and it seems to
have installed.
4)noticed the theme isnt showing up in details view
5)close g-t-m and restart....BOOM application crash... repeatably
6)run strace gnome-theme-manager 2>/dev/null no crash and the theme is
in details for Window Border themes... repeatably.

Do i need to make a new clean test user to make sure this is not
something gross in my userspace for that particular user?  Do you have
any theory as to why this works when i run it under strace?

-jef


Comment 10 Thomas J. Baker 2004-09-14 11:20:14 EDT
Actually, I'm now getting the same crash again too. I haven't run
g-t-m in a while and seeing this bug report made me try it again. It
works running strace'd but not normally. I even removed my .themes and
.icons directories and it still crashes unless straced. I then tried
it on my clean gnome test account on a different system (both are up
to date rawhide) and it works fine. I installed the office Metacity
theme, used the office theme, switched back to glider, all sorts of
permutations and I can't get it to crash.
Of course, now I go back to the system and account that was crashing
and it doesn't crash all the time now, just sporadically. I'll include
a non-debuginfo crashlog shortly.
Comment 11 Thomas J. Baker 2004-09-14 11:21:31 EDT
Created attachment 103830 [details]
gtm backtrace
Comment 12 Jef Spaleta 2004-09-16 00:29:30 EDT
here is a heads up I'm also seeing this consistently with
the gnome-keybinding-properties. Crashing on normal execution by works
under strace. Sorry i didn't get through all the control-center
executables quicker....there are just so many of them.

-jef

 
Comment 13 Jef Spaleta 2004-10-13 08:45:49 EDT
I little more info on a box that is rawhide synced as of oct 12.
on first login of a user after a reboot, g-t-m starts up normally and
I can choose a new theme to use without a problem. Closing g-t-m and
restarting it gives me the crash dialog. I logout, make sure all the
user processes have stopped, and relogin and g-t-m will start again
without incident. But once I make a theme selection in a login session
g-t-m will not start again afterwords until i relogin.  Is this a
gconf interaction issue?

running g-t-m under strace always works.

-jef
Comment 14 Jef Spaleta 2004-11-26 21:28:47 EST
just checking in fresh install of fc3 and i can still reproduce the
crash and running under strace always works.
control-center-2.8.0-12
Comment 15 Jonathan Underwood 2004-12-03 20:44:52 EST
I am seeing exactly the same issue with gnome-keybinding-properties. 
I did a fresh install of FC3 onto my box, but used an old user account
on my /home partition that had been used with the previous FC2
install. gnome-keybindings properties segfaults when ran as this user.
It doesn't segfault when run under strace. If i create a brand new
account and run g-k-p from there, it functions fine.  I deleted
.gnome* .gconf* .themes .icons .gtkrc and .pan, and tried again -
still segfaults.  I even tried copying these across from the new user
account where it function ok, but, no joy.  So there's an interaction
with something.  What files does g-k-p look for?

control-center-2.8.0-12 also. 
Comment 16 Jonathan Underwood 2004-12-03 21:01:13 EST
Just confirmed that I see the same thing with g-t-m, even though I
have no additional themes installed.
Comment 17 Jef Spaleta 2004-12-03 21:21:53 EST
Re comment 15 and comment 16
Let me stress....
i see this with g-t-m after installing a new theme even for newly
created users on an fc3 system.
for example installing  MCity-Office_0.7.tar.bz2 from art.gnome.org
on a freshly created user on fc3 using g-t-m.
Once the install of the theme is complete... if I try to open g-t-m
again without running under strace i get a segfault.


Comment 18 Jonathan Underwood 2004-12-06 08:38:47 EST
Following more investigation, I tracked down what I believe is the
root of the problem I am seeing, and I suspect is very similar in
origin to that that Jef is seeing. From a clean FC3 install, and a
brand new account, gnome-keybinding-properties functions ok. If one
opens gnome-keyboard-properties and adds "Make CapsLock an additional
Control" and subsequently tries to open gnome-keybinding-properties,
it now segfaults. Similarly with gnome-theme-manager. So, it's a bug
with the way that gnome-keyboard-properties is interacting with
gnome-keybinding-properties and g-t-m.

Is this sufficiently similar to the bug Jef has reported here, or
shall I open a seperate bugzilla report?
Comment 19 Phil Hale 2004-12-17 11:00:10 EST
I've been having the same issues with both gnome-keybindings and
gnome-theme-manager as well. FC3 X86_64 build.
Comment 20 Eric Jones 2005-03-22 11:53:27 EST
This issue has just recently popped up for me on Enterprise 4 (no doubt since it
is based on FC3).  I've tried every combination of removing user directory trees
(.gconf* .gnome* .gtk* .icons .themes) and this has no effect.  Running it under
strace has no effect.  Log out and run as root and it works fine, run as root
without logging out works fine.  You can manually change themes in gconf and
they are applied, but everytime that gnome-theme-manager is started it
immediately crashes.  Should I open a separate bug for Enterprise 4?
Comment 21 Ray Strode [halfline] 2005-04-15 16:08:52 EDT
Hi,
Is anyone seeing this in rawhide still?  I can't.  This may have been fixed
already (Of course if it has been fixed we still need to find out what the fix
was and push an fc3 update).
Comment 22 Jef Spaleta 2005-04-16 16:52:36 EDT
Re: comment 21
I just tried installing both gtk2 and metacity themes as a normal user from
art.gnome.org  on my rawhide box.  No more crashes. This use to be my reliable
way to produce the problem. So it appears to me to be fixed in rawhide.

control-center-2.10.1-1  is installed on this box.


-jef
Comment 23 Ray Strode [halfline] 2005-04-18 10:37:19 EDT
Okay, let's drop this from the FC4 tracker then.
Comment 24 Paolo Prandini 2005-05-08 15:40:23 EDT
Hi

I got the same problems reported here.
I cannot upgrade to rawhide, stick with my FC3 box.
What can I do?

- Regards
- Pasha
Comment 25 Paolo Prandini 2005-05-08 15:42:52 EDT
Created attachment 114142 [details]
strace of gnome-theme-manager
Comment 26 Ray Strode [halfline] 2005-05-09 10:00:24 EDT
Hi Paolo,

We are nearing toward the end of the FC4 development cycle, so this bug probably
won't get looked at for a few weeks so that resources can be directed toward
fixing FC4 blocker bugs.  You can try upgrading to the rawhide control-center to
see if that fixes your problem, or alternatively you can try one of the FC4 test
releases.
Comment 27 Paolo Prandini 2005-05-09 14:43:36 EDT
Hi Ray, 

You have my full understanding, thanks for reply. FC4 is so close...
I have downloaded the rawhide package, but it has too many
dependancies that I had to use the --nodep (shame on me) option
to install. Even so the new rawhide relies on these dependancies so
it did not even start.
I'll wait for FC4 then I'll see.
In the meantime my workaround is using strace without any option
(80% of times) it works. Strange to say strace -o filename almost always
crashes and starce -c follows the same path....

- Best Regards
- Paolo

PS : The FC4 wait begins....
Comment 28 Jef Spaleta 2006-03-25 19:47:43 EST
As the original reporter I'm going to close this out. FC3 is now eol and if
someone needs to track this issue as part of Fedora Legacy, please refile a new
bug. 

-jef 

Note You need to log in before you can comment on or make changes to this bug.