This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1291031 - "Select All" button on Satellite 5.7 Web UI ignores filters and selects all packages
"Select All" button on Satellite 5.7 Web UI ignores filters and selects all p...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
570
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Grant Gainey
Ales Dujicek
:
: 962407 (view as bug list)
Depends On:
Blocks: 465198 sat570-triage sat570-postga
  Show dependency treegraph
 
Reported: 2015-12-12 19:50 EST by Peter
Modified: 2017-02-02 10:10 EST (History)
6 users (show)

See Also:
Fixed In Version: spacewalk-java-2.3.8-140-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-02 08:33:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 376853 None None None 2016-03-13 07:11 EDT
Red Hat Knowledge Base (Solution) 414283 None None None 2016-03-13 07:10 EDT

  None (edit)
Description Peter 2015-12-12 19:50:59 EST
Description of problem:
the issue of "Select All" button on the satellite 5.7 Web UI


Version-Release number of selected component (if applicable):
Satellite 5.7

How reproducible:
Two scenes to reproduce this issue:
(1) scene one: Erratas page
During generating own Erratas for infrastructure Packages, we searched for Packages. Example:
Looking for packages which ends with 6-6.6.0.50. The satellite found three packages. And now we have the choice to add every package separately, click the check button above (add all listed packages) or choose the button "Select All". If I choose "Select All", the Satellite starts to collect all packages available in Satellite!
(2) scene two: channel and systems pages
a) A channel admin tried to delete _some_ packages from a custom channel. After filtering the channel, if the user clicked "Select All" button and then "Delete" button, it will end up deleting _all_ packages from the channel.
b) A system admin tried to delete _some_ hosts from the satellite. After filter the hosts, if the user clicked "Select All" button and then "Delete" button, it will end up deleting _all_ hosts from the satellite.

Steps to Reproduce:
https://rhel6-sat57-2.gsslab.rdu2.redhat.com/rhn/Login.do
Errata -> Manage Errata -> Unpublished Errata
1. go to Erratas page
2. input some key words to filter, then click search button (eye button)
3. click "Select All" button
4. click "Delete Errata"
5. A new page display, it will show all errata

Actual results:
After clicking "Delete Errata", a new page display, it will show all erratas to delete 

Expected results:
It will display the filtered errata to delete


Additional info:
Case ID: 01547357

In addition, I found the link "Download CSV" has the same issue. Take users management page for example, although I have done some filter on the page, when I click "Download CSV", it will download all the users in the csv file.
Comment 1 Tomas Lestach 2015-12-14 05:02:33 EST
This looks like a duplicate of Bug 962407
Comment 2 Peter 2015-12-15 18:05:02 EST
(In reply to Tomas Lestach from comment #1)
> This looks like a duplicate of Bug 962407

Hi Tomas,

Thanks. You are right, it is the same bug, I guess.

But that bug was opened in 2013 and has not been fixed.
Comment 7 Tomas Lestach 2016-02-29 06:41:15 EST
*** Bug 962407 has been marked as a duplicate of this bug. ***
Comment 10 Grant Gainey 2016-03-28 16:45:13 EDT
spacewalk.github:
083d7b6e4c3416372d7c5f44a1cb5d8b2a4d7c4f

This commit adds the requested SelectAll behavior to the New ListTag infrastructure and all pages that take advantage of it. Unfortunately, there are still ~60 JSPs that rely on the Old ListTag, and will require extensive refactoring to move them to the new-improved scheme of things.

This fix addresses the New ListTag-affected pages. More work remains to be done.
Comment 11 Grant Gainey 2016-04-27 15:00:05 EDT
The manage-errata pages specifically mentioned in this BZ migrated to NewListTag to be able to pick up the corrected behavior:

spacewalk.github:
a89aa0ec428e6a115605cb1d919c92153b6b842a
6b3c59a620bddae6bec2b482a1e637e8e652ba95
Comment 23 Grant Gainey 2016-05-18 16:36:26 EDT
spacewalk.github:
852d951c995e0e7c71183e4446dc40871abddd59
Comment 29 errata-xmlrpc 2016-06-02 08:33:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1200
Comment 30 Grant Gainey 2017-02-02 10:10:31 EST
NOTE: this fix is an invasive change to some significant infrastructure and pages. Backporting to previous releases is *not* trivial.

Note You need to log in before you can comment on or make changes to this bug.