Bug 1291165 - [RFE] backup mode for a domain (temporarily disallow running VMs from a specific domain, as it's being backed up)
[RFE] backup mode for a domain (temporarily disallow running VMs from a speci...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
4.0.0
Unspecified Unspecified
low Severity medium (vote)
: ovirt-4.2.1
: ---
Assigned To: Shubbham Dubey
Elad
: FutureFeature
Depends On: 1502559 1541769
Blocks: 1291168 Gluster-HC-3 1508270 1548850
  Show dependency treegraph
 
Reported: 2015-12-14 03:22 EST by Allon Mureinik
Modified: 2018-03-01 02:29 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Configuring a storage domain as backup storage domain, so user can backup VMs and Templates while the storage domain is attached to oVirt Reason: Export storage domain is a dedicated storage domain which is used to store and restore VMs and Templates. The drawback of Export storage domain is its two stage process. Transferring a VM required first copying it into the export storage domain and then into other storage domain to start using them. Since in background transfer from one domain to other take place using normal copy or dd utility (in case of disks) this process take a large time for a complete transfer. Result: For a better backup experience we decided to create a whole dedicated storage domain to be used only for backup which obviously will call as backup storage domain.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-22 05:00:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
ratamir: testing_plan_complete?
ylavi: planning_ack+
amureini: devel_ack+
ratamir: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79035 None None None 2017-09-11 05:37 EDT
oVirt gerrit 81290 master MERGED backend: added validation for backup storage domain 2017-12-20 03:11 EST

  None (edit)
Description Allon Mureinik 2015-12-14 03:22:15 EST
Description of problem:
With the ability to attach/detach a data domain, it can virtually replace an export domain.

The missing piece is a "backup-mode" flag to allow the user to prevent running VMs on the copies he intends for a backup.
Comment 1 Allon Mureinik 2017-06-12 03:47:31 EDT
Actually, this is being worked on as part of oVirt's participation in GSOC.
Comment 2 Yaniv Lavi 2017-08-13 07:04:21 EDT
A nice follow up would be to allow to attach this domain a number of DCs and RHV managers to enable easier template sharing with OVA/templates. Should we open an RFE for this?
Comment 3 Allon Mureinik 2017-08-13 07:31:47 EDT
(In reply to Yaniv Lavi (Dary) from comment #2)
> A nice follow up would be to allow to attach this domain a number of DCs and
> RHV managers to enable easier template sharing with OVA/templates. Should we
> open an RFE for this?

I'd like to point out that this isn't *that* easy.
Nothing in this feature changes the locking implementation, so there's quite a bit of extra work to add the improvement you're requesting. Let's have a separate RFE for it so we can design/scope/prioritize there.
Comment 7 Maor 2017-10-15 04:42:59 EDT
Shubham,

Can you please open a separate bug for the fix in https://gerrit.ovirt.org/#/c/81290/
and block this bug on the new opened bug.
I think that once that will be done we can move this bug to ON_QA
Comment 8 Raz Tamir 2017-10-15 04:46:22 EDT
Maor,

Can you please provide more information about this RFE?
Is there any feature page for it?
Comment 9 Maor 2017-10-15 05:17:50 EDT
You can take a look at the feature page here:
https://github.com/oVirt/ovirt-site/pull/1003
Comment 10 Elad 2018-02-19 07:33:04 EST
Feature functionality works properly, the following operations are blocked:
- VM start, with an attached disk on a backup domain 
- Setting a domain to backup while it has disks attached to running VMs
- Live storage migration to a backup domain (as bug #1541769 is now fixed and verified)


Used:
rhvm-4.2.2-0.1.el7.noarch
Comment 11 Sandro Bonazzola 2018-02-22 05:00:47 EST
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.