Bug 1291173 - [RFE] Putting a RHS node into maintenance mode currently seems to do nothing.
[RFE] Putting a RHS node into maintenance mode currently seems to do nothing.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Console_Administration_Guide (Show other bugs)
3.1
All Linux
high Severity medium
: ---
: ---
Assigned To: Anjana Suparna Sriram
RHS-C QE
: Documentation, FutureFeature, ZStream
Depends On: 1189285 1230247 1277562 1286636 1286638 1289092 1294754
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-12-14 03:49 EST by Ramesh N
Modified: 2016-07-07 08:55 EDT (History)
22 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1189285
Environment:
Last Closed: 2016-07-07 08:55:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 43725 None None None Never
oVirt gerrit 43773 master MERGED engine: check gluster params while moving Host to maintenance 2016-09-20 01:48 EDT
oVirt gerrit 43821 None None None Never
oVirt gerrit 48995 None None None Never

  None (edit)
Comment 4 Ramesh N 2016-01-20 06:38:29 EST
I have verified the sections "6.2.2. Activating Hosts", "6.2.5. Deleting Hosts" and "6.3.1. Moving Hosts into Maintenance Mode". These are the only places where host is moved to maintenance or host is activated. Changes looks good.
Comment 6 Sahina Bose 2016-01-29 01:19:12 EST
Under "Deleting Hosts" -
The note mentions - "If you move the Host under Maintenance mode, it will stop all gluster process such as brick, self-heal, and geo-replication. Once the Host is activated, all gluster processes will be restarted automatically. "
The activation bit is not relevant under Deletion.
Would it be appropriate to mention in the note, that since the gluster services are stopped, the gluster peer detach does not remove the gluster related info stored under /var/lib/glusterd, and this will need to be manually cleared before the host can be re-added to another cluster?
Comment 8 Sahina Bose 2016-02-05 02:39:20 EST
Under "Deleting Hosts" -
"If you wish to resue this host, ensure to remove the gluster related information stored in /var/lib/glusterd manually. All gluster processes will be restarted automatically once the host is activated. "

typo in reuse.

"All gluster processes will be restarted automatically once the host is activated." - remove this line from this note. It is not relevant under "Deleting Hosts" section
Comment 9 Sahina Bose 2016-02-08 03:21:22 EST
Changes look good.

Note You need to log in before you can comment on or make changes to this bug.