Bug 1291246 - [ppc64le] Not possible to create vm from scratch via REST on PPC
[ppc64le] Not possible to create vm from scratch via REST on PPC
Status: CLOSED DUPLICATE of bug 1253263
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.1.3
ppc64le Unspecified
unspecified Severity high (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: nobody nobody
Ilanit Stein
:
Depends On:
Blocks: RHEV3.6PPC
  Show dependency treegraph
 
Reported: 2015-12-14 07:00 EST by Ondra Machacek
Modified: 2016-03-14 05:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 03:53:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michal.skrivanek: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2015-12-14 07:00:28 EST
Description of problem:
version of cluster is 3.6, arch PPC64, cpu ibm power 8

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.  curl -k -X POST -H "Accept: application/xml" -H "Content-Type: application/xml" -H "Filter: $filter"
  -d "<vm><name>testingREST2</name><cluster id=\"e5fe8bf0-1850-4b7c-ad19-3787254c1630\"/><template id=\"00000000-0000-0000-0000-000000000000\"/></vm>"
  -u $U $URL/vms/

Actual results:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<fault>
    <reason>Operation Failed</reason>
    <detail>[Cannot add VM. Selected display type is not supported by the operating system.]</detail>
</fault>


Expected results:
Added successfully

Additional info:
2015-12-14 13:37:59,602 WARN  [org.ovirt.engine.core.bll.AddVmFromScratchCommand] (ajp-/127.0.0.1:8702-8) [] CanDoAction of action 'AddVmFromScratch' failed for user admin@internal. Reasons: VAR__ACTION__ADD,VAR__TYPE__VM,ACTION_TYPE_FAILED_ILLEGAL_VM_DISPLAY_TYPE_IS_NOT_SUPPORTED_BY_OS
2015-12-14 13:37:59,602 INFO  [org.ovirt.engine.core.bll.AddVmFromScratchCommand] (ajp-/127.0.0.1:8702-8) [] Lock freed to object 'EngineLock:{exclusiveLocks='[rhel5_x64_Disk1=<VM_NAME, ACTION_TYPE_FAILED_OBJECT_LOCKED>]', sharedLocks='null'}'
2015-12-14 13:37:59,612 ERROR [org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp-/127.0.0.1:8702-8) [] Operation Failed: [Cannot add VM. Selected display type is not supported by the operating system.]
Comment 1 Michal Skrivanek 2015-12-15 01:57:56 EST
display is inherited from template. "Blank" has "SPICE"
Either provide explicitly VNC display or use a different template
Comment 2 Michal Skrivanek 2015-12-15 02:23:12 EST
We don't plan to fix this now, but I think going forward it may make sense to inherit a default display type from OS type, and we already have a different "default OS type" for x86 vs ppc64le
Comment 3 Ilanit Stein 2015-12-20 01:38:00 EST
Duplicate of bz 1253263?
Comment 4 Yaniv Kaul 2016-03-13 11:23:58 EDT
(In reply to Ilanit Stein from comment #3)
> Duplicate of bz 1253263?

Is it?
Comment 5 Ondra Machacek 2016-03-14 03:53:58 EDT

*** This bug has been marked as a duplicate of bug 1253263 ***

Note You need to log in before you can comment on or make changes to this bug.