Bug 129129 - RFE: needs firewall hook
RFE: needs firewall hook
Status: CLOSED DUPLICATE of bug 440469
Product: Fedora
Classification: Fedora
Component: system-config-firewall (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
bzcl34nup
: FutureFeature
: 134382 159605 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-04 06:26 EDT by Tim Waugh
Modified: 2009-06-03 10:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 10:04:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-08-04 06:26:45 EDT
Description of problem:
This is another application that needs a hook in our network code to
ask whether a particular port is blocked, and advise the user what to
do if that is the case.

As it is, vino will mysteriously not work -- the answer is to open a
particular port number but how is the user to know?
Comment 1 Mark McLoughlin 2004-08-04 07:21:59 EDT
Yeah, totally. Any ideas on that or are you just saying that this is a
general problem which we haven't figured out a solution to?

We can do the NTP thing (open the port on boot) for system wide
services, but per-user services?
Comment 2 Tim Waugh 2004-08-04 07:39:43 EDT
It's a general problem; just noting another need for it.

Another that springs to mind is print queue browsing (IPP) -- not sure
at this point if that's meant to be per-user or per-system.
Comment 3 Mark McLoughlin 2004-10-04 10:21:59 EDT
*** Bug 134382 has been marked as a duplicate of this bug. ***
Comment 4 Tim Waugh 2005-06-06 12:10:31 EDT
*** Bug 159605 has been marked as a duplicate of this bug. ***
Comment 5 Bug Zapper 2008-04-03 11:37:44 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 6 Tim Waugh 2008-04-03 11:42:08 EDT
Changing version and component.  This is still an issue -- more so with the
coming Fedora 9 with stricter firewall settings.
Comment 7 Tim Waugh 2008-04-03 11:43:20 EDT
The 'I am providing the requested information for this bug' checkbox didn't work
-- changing to ASSIGNED instead.
Comment 8 Thomas Woerner 2008-04-03 12:40:24 EDT
The VNC port was never open by default, so why is this more an issue with Fedora 9?
Comment 9 Tim Waugh 2008-04-03 13:14:11 EDT
The general problem noted in comment #2 is more of an issue with Fedora 9.
Comment 10 Thomas Woerner 2008-07-22 08:17:17 EDT
This is a RFE for rawhide.
Comment 11 John Poelstra 2008-07-22 19:58:45 EDT
features should get the 'FutureFeature' keyword
Comment 12 Thomas Woerner 2009-06-03 10:04:52 EDT

*** This bug has been marked as a duplicate of bug 440469 ***

Note You need to log in before you can comment on or make changes to this bug.