Bug 1291340 - Backport --family option from upstream
Summary: Backport --family option from upstream
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: chkconfig   
(Show other bugs)
Version: 7.2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Jan Ščotka
Maxim Svistunov
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks: 1289485 1313485 1296413 1296414
TreeView+ depends on / blocked
 
Reported: 2015-12-14 15:43 UTC by Lukáš Nykrýn
Modified: 2016-11-04 06:56 UTC (History)
3 users (show)

Fixed In Version: chkconfig-1.7.1-1.el7
Doc Type: Enhancement
Doc Text:
New "--family" option for the *alternatives* utility This update introduces the new "--family" option for the *alternatives* utility. The software packager can use this option to group similar alternative packages from the same group into families. Families inside groups ensure that if the currently used alternative is removed, and it belonged to a family, then the current alternative will change to package with the highest priority within the same family, and not outside the family. For example, a system has four packages installed in the same *alternatives* group: _a1_, _a2_, _a3_, _b_ (listed in increasing priority). Packages _a1_, _a2_, and _a3_ belong to the same family. _a1_ is the currently used alternative. If _a1_ is removed, then the currently used alternative will change to _a3_. It will not be _b_, because _b_ is outside the family of _a1_, and it will not be _a2_, because _a2_ has lower priority than _a3_. This option is useful when just setting priorities for each alternative is not enough. For example, all _openjdk_ packages can be put into the same family to ensure that if one of them is uninstalled, the alternative will switch to another _openjdk_ package, and not to the _java-1.7.0-oracle_ package (if another _openjdk_ package is installed).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 06:56:38 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2467 normal SHIPPED_LIVE chkconfig bug fix and enhancement update 2016-11-03 14:06:42 UTC

Description Lukáš Nykrýn 2015-12-14 15:43:52 UTC
SSIA

Comment 1 jiri vanek 2016-01-07 08:22:31 UTC
Hello! 

I'm going to request bugs for openjdk7 and 8, so small story to avoid copypaste in them:

Openjdk is supporting parallel instalaltions. So in same time you can have eg:
java-1.7.0-openjdk-v1
java-1.8.0-openjdk-v1

as targets of "java" or "javac" alternatvies keys. Which one is proffered, says priority.
the above have priorities eg:
1701
1801

Now - you select openjdk 7 as your target, and do update. So your jdks will change to:
java-1.7.0-openjdk-v2
java-1.8.0-openjdk-v2
with priorities
1702
1802

That means that 1802 > then 170X and your selection of jdk7 will switch to jdk8.

Thats what new --family switch is going to solve.
The priorities will be:
1701 family java-1.7.0-openjdk
1801 family java-1.8.0-openjdk

When target with family is selected, then then family is remembered, and selection will not leave family if thetre is still another target of same family so above example of update will now correctly stay on java-1.7.0-openjdk.


This issue is affecting:
java-1.6.0-openjdk
java-1.7.0-openjdk
java-1.8.0-openjdk

java-1.6.0-oracle
java-1.7.0-oracle
java-1.8.0-oracle

java-1.6.0-ibm
java-1.7.0-ibm
java-1.8.1-ibm

There will be regular udpate of openjdk 6,7,8 and form those 7 and 8 will be requesting --family change for 7.3

Other javas will get this change async (as they always do)

Comment 6 errata-xmlrpc 2016-11-04 06:56:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2467.html


Note You need to log in before you can comment on or make changes to this bug.