Bug 1296414 - Enable --family in alternatives in openjdk8
Enable --family in alternatives in openjdk8
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: java-1.8.0-openjdk (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: jiri vanek
Lukas Zachar
Robert Krátký
:
Depends On: 1291340
Blocks: 1297579 1313485
  Show dependency treegraph
 
Reported: 2016-01-07 03:24 EST by jiri vanek
Modified: 2016-11-03 18:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: java-1.8.0-openjdk-1.8.0.92-5.b14.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 18:55:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jiri vanek 2016-01-07 03:24:53 EST
please see:
https://bugzilla.redhat.com/show_bug.cgi?id=1291340#c1

there already is erratumfor openjdk8
Comment 3 jiri vanek 2016-06-21 14:16:54 EDT
For record. Small design issue was found.
AS family, should be considered java-version-vendor.arch - not only java-version-vendor.

<jvanek> http://pkgs.fedoraproject.org/cgit/rpms/java-1.8.0-openjdk.git/tree/java-1.8.0-openjdk.spec#n271
<jvanek> is how it looks now
<jvanek> --install %{_bindir}/java java %{jrebindir %%1}/java $PRIORITY  --family %{name}.%{_arch}\\
<jvanek> is how it will look like


Otherwise update of multilib system is undeterministic.
Comment 6 errata-xmlrpc 2016-11-03 18:55:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2139.html

Note You need to log in before you can comment on or make changes to this bug.