Bug 129135 - wget-1.9.1-5 fails to download file with long ftp url (reclassify as kernel bug)
Summary: wget-1.9.1-5 fails to download file with long ftp url (reclassify as kernel bug)
Status: CLOSED DUPLICATE of bug 129204
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-04 12:30 UTC by Goh Kim Leng
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Goh Kim Leng 2004-08-04 12:30:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
wget-1.9.1-5 fails to download file with long ftp url and the words 
ftp in the domain name. The file is of size 1.5M:

wget ftp://ftp.tin.org/pub/news/clients/tin/stable/tin-current.tar.gz
--19:46:57--  ftp://ftp.tin.org/pub/news/clients/tin/stable/tin-
current.tar.gz
           => `tin-current.tar.gz'
Resolving ftp.tin.org... 129.13.251.67
Connecting to ftp.tin.org[129.13.251.67]:21... connected.
Logging in as anonymous ...


wget just hangs there. However, another url works for wget:

wget ftp://ftp.funet.fi/pub/unix/news/tin-unoff/tin-current.tar.gz
--20:05:40--  ftp://ftp.funet.fi/pub/unix/news/tin-unoff/tin-
current.tar.gz
           => `tin-current.tar.gz'
Resolving ftp.funet.fi... 193.166.3.2
Connecting to ftp.funet.fi[193.166.3.2]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /pub/unix/news/tin-unoff ... done.
==> PASV ... done.    ==> RETR tin-current.tar.gz ... done.

Version-Release number of selected component (if applicable):
wget-1.9.1-5

How reproducible:
Always

Steps to Reproduce:
1. type wget ftp://ftp.tin.org/pub/news/clients/tin/stable/tin-
current.tar.gz
2.
3.
    

Additional info:

kernel release is 2.6.7-1.494.2.2smp

Comment 1 Goh Kim Leng 2004-08-07 04:58:10 UTC
I've reclassified the component from wget to kernel. This is because 
this version of wget works under kernel-smp-2.6.6-1.435.2.3 for the 
specific example above. 

Moreover, I discovered that the average speed for downloads via wget 
or elinks for kernel-2.6.7-1.494.2.2smp was in B/s. The file I was 
attempting to download was the J2SE v 1.4.2_05 SDK RPM in self-
extracting file. On the other hand, the download using kernel-smp-
2.6.6-1.435.2.3 was in K/s.

Comment 2 Goh Kim Leng 2004-08-07 05:05:22 UTC

*** This bug has been marked as a duplicate of 129204 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:04:56 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.