Bug 129204 - 2.6.7.1.494.2.2 Kernel Networking Problem
2.6.7.1.494.2.2 Kernel Networking Problem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 129135 129136 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-04 20:59 EDT by George Salt
Modified: 2015-01-04 17:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 01:00:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Salt 2004-08-04 20:59:05 EDT
Description of problem:  My FC2 computer is on a LAN with Win98SE and
Win2k computers.  Often I transfer files from the Win computers to the
FC2 computer.  I have Samba 3.0.3.5 installed.  

I use the Nautilus file browser to open a window for the share on the
Win computer, open another window for a directory on the FC2 computer,
and simply drop-and-drag files from one window to another.  This works
fine for kernels up through 2.6.6-1.435.2.3

Recently I installed the new 2.6.7-1.494.2.2 kernel.  Now, when I try
to drop-and-drag files, the "copying files" window freezes.  When I
reboot with the older kernel, I can transfer files as before.


Version-Release number of selected component (if applicable):
2.6.7.1.494.2.2 kernel 

How reproducible:
always

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:  file transfer freezes


Expected results:  normal file transfer


Additional info:
Comment 1 Monte Ohrt 2004-08-05 11:18:35 EDT
I have spurratic TCP hang problems with the new kernel
(2.6.7-1.494.2.2). My Mail client hangs when getting mail, my browser
hangs when loading web pages, my ssh client hangs when typing
commands. Downgrading to 2.6.6-1.435.2.3 solved the problem.
Comment 2 Goh Kim Leng 2004-08-07 01:05:03 EDT
*** Bug 129136 has been marked as a duplicate of this bug. ***
Comment 3 Goh Kim Leng 2004-08-07 01:05:23 EDT
*** Bug 129135 has been marked as a duplicate of this bug. ***
Comment 4 Need Real Name 2004-08-09 12:02:31 EDT
Getting the same problem here, a bunch of TCP connections that worked
fine under kernel-2.6.6-1.435.2.3 are now broken under
kernel-2.6.7-1.494.2.2.  For instance, I normally have several SSH
sessions open (to Linux and FreeBSD boxes).  Some of those no longer
work, the SSH client hangs before ever authenticating.
Comment 5 Thorsten Leemhuis 2004-08-09 14:14:30 EDT
Please see this thread for a possible fix:

http://www.redhat.com/archives/fedora-list/2004-August/msg01490.html

Worked for me, too. ;-)
Comment 6 Need Real Name 2004-08-09 17:15:01 EDT
Indeed.

This does "fix" the issue I was having.  However, I didn't have to set
both of the variables, just the following one:

net.ipv4.tcp_default_win_scale=0

Thanks for finding this solution.
Comment 7 George Salt 2004-08-11 15:35:21 EDT
This solved the file tranfer problem I originally reported.

Thanks so much.  This is what I love about the open source community.

Open Source Rocks!
Comment 8 Goh Kim Leng 2004-08-20 10:23:05 EDT
Solved my wget and curl problem too. However, the bug still exists 
fro kernel-2.6.8.1.

For the benefit of others who don't want to look through other threads
(http://www.linuxarkivet.se/mlists/linux-net/0406/msg00230.html), you 
can do the following:

Add the following to /etc/sysctl.conf and reboot:

# The following solves a kernel networking problem with kernel-2.6.7-
1.494.2.2, kernel-2.6.8-1.521. If you finally do not need
 it, just comment them with a leading #.
net.ipv4.tcp_default_win_scale = 0
Comment 9 Goh Kim Leng 2004-08-20 13:58:00 EDT
this thread is similar to 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=126626
Comment 10 Goh Kim Leng 2004-08-20 14:05:04 EDT
more info at http://lwn.net/Articles/91976/
Comment 11 Dave Jones 2004-11-27 17:33:49 EST
mass update for old bugs:

Is this still a problem in the 2.6.9 based kernel update ?
Comment 12 Need Real Name 2004-11-28 16:53:24 EST
I no longer have an FC2 system to test with (they've both been
upgraded to FC3), but FC3 no longer appears to have the
net.ipv4.tcp_default_win_scale sysctl:

$ uname -r
2.6.9-1.681_FC3

$ /sbin/sysctl net.ipv4.tcp_default_win_scale
error: 'net.ipv4.tcp_default_win_scale' is an unknown key

Everything does appear to work fine, though.

Note You need to log in before you can comment on or make changes to this bug.