Bug 1291371 - konsole does not start reliably
konsole does not start reliably
Status: CLOSED DUPLICATE of bug 1291260
Product: Fedora
Classification: Fedora
Component: konsole5 (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 12:26 EST by long
Modified: 2016-01-28 06:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 06:54:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description long 2015-12-14 12:26:31 EST
Description of problem:
When I start konsole I have to start two or more instances before it actually works.  The first instance or two displays a transparent window and title bar and does nothing.  

Version-Release number of selected component (if applicable):
konsole5-15.08.3-1.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Login to kde
2. Right click desktop, "Konsole" or open an xterm and run "konsole"
3.

Actual results:
Transparent konsole window with title bar is created.  In the xterm it says:
[long@kite .config]$ konsole
QCoreApplication::arguments: Please instantiate the QApplication object first
[long@kite .config]$ The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
0x5631602bc1a0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x56315ff9ea40) ): Attempt to set a screen on a child window.
0x563160313730 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x56315ff9ea40) ): Attempt to set a screen on a child window.
0x563160313b80 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x56315ff9ea40) ): Attempt to set a screen on a child window.
0x563160332af0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x56315ff9ea40) ): Attempt to set a screen on a child window.
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1620, resource id: 23068769, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1628, resource id: 23068769, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1636, resource id: 23068769, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1642, resource id: 23068769, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1650, resource id: 23068769, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1663, resource id: 23068769, major code: 130 (Unknown), minor code: 3


Expected results:
A working konsole window

Additional info:
Comment 1 Rex Dieter 2015-12-14 12:48:03 EST
Do you have multiple displays?  Are you using nvidia drivers?
Comment 2 long 2015-12-14 12:51:14 EST
Hi, I do have two displays.  I am not using nvidia drivers, it is intel drivers.
Comment 3 Martin Kho 2015-12-28 05:18:42 EST
Hi,

Same issue here with 2 monitors and AMD graphics card (R600g driver). When I start several instances of konsole (>5) plasmashell is getting very unstable. For instance, this shows up when switching desktops.

HTH

Martin Kho
Comment 4 Martin Kho 2015-12-28 07:42:35 EST
Hi,

Update: It seems that this issue has indeed to do with two-monitor setup. When konsole opens on my primary screen it works as expected, on the secondary screen it fails.

Martin Kho
Comment 5 Rex Dieter 2016-01-28 06:54:26 EST

*** This bug has been marked as a duplicate of bug 1291260 ***

Note You need to log in before you can comment on or make changes to this bug.