Bug 1291260 - First konsole window launched is unusable
First konsole window launched is unusable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: plasma-breeze (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
: 1291371 1293236 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 07:59 EST by Paul Black
Modified: 2016-02-03 08:24 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 08:24:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 356343 None None None 2016-01-28 06:49 EST

  None (edit)
Description Paul Black 2015-12-14 07:59:20 EST
Description of problem:
First konsole5 launches with a transparent window when launched from panel icon, second and subsequent ones are fine (condition re-occurs if all are closed). konsole launched from right-click of desktop always seems to be fine.


Version-Release number of selected component (if applicable):
plasma-workspace-5.5.0-2.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Click on konsole icon on panel (application dashboard icon shows same symptom).


Actual results:
Only get title bar of konsole window.

Expected results:
Get normal window.

Additional info:
Right-click brings up konsole menu. Shell commands entered are executed. This is not an issue with the recent konsole update; that came last week and was fine. There were several other "plasma" updates (and some other KDE ones) as well.

The following messages get dumped into ~/.xsession-errors at the same time:
QXcbConnection: XCB error: 3 (BadWindow), sequence: 35502, resource id: 37748741, major code: 141 (Unknown), minor code: 3
QXcbConnection: XCB error: 3 (BadWindow), sequence: 53816, resource id: 79691777, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 53828, resource id: 79691778, major code: 18 (ChangeProperty), minor code: 0
QCoreApplication::arguments: Please instantiate the QApplication object first
QXcbConnection: XCB error: 3 (BadWindow), sequence: 53842, resource id: 79691777, major code: 18 (ChangeProperty), minor code: 0
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
0x5597697005e0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5597693e55c0) ): Attempt to set a screen on a child window.
0x559769700b80 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5597693e55c0) ): Attempt to set a screen on a child window.
0x559769701020 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5597693e55c0) ): Attempt to set a screen on a child window.
0x55976976fa90 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5597693e55c0) ): Attempt to set a screen on a child window.
0x559769701020 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5597693e55c0) ): Attempt to set a screen on a child window.
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1635, resource id: 79691873, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1645, resource id: 79691873, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1653, resource id: 79691873, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1661, resource id: 79691873, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1662, resource id: 79691873, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1694, resource id: 79691873, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1701, resource id: 79691873, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1712, resource id: 79691873, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1737, resource id: 79691873, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1748, resource id: 79691873, major code: 130 (Unknown), minor code: 3



For a working windows, I only get :
QXcbConnection: XCB error: 3 (BadWindow), sequence: 9692, resource id: 88080385, major code: 18 (ChangeProperty), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 9696, resource id: 88080386, major code: 18 (ChangeProperty), minor code: 0
QCoreApplication::arguments: Please instantiate the QApplication object first
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
0x5595eaa9f840 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x5595ea5ee6e0) ): Attempt to set a screen on a child window.
QXcbConnection: XCB error: 8 (BadMatch), sequence: 2875, resource id: 79691873, major code: 130 (Unknown), minor code: 3
Comment 1 Jaroslav Reznik 2016-01-08 02:59:44 EST
I'm hitting the same issue but even second window is broken and no luck with desktop right click neither.
Comment 2 Felix Homann 2016-01-11 10:02:56 EST
Same here. Besides konsole chrome often shows the exact same behaviour, not sure if it's related, though.
Comment 3 Rex Dieter 2016-01-28 06:48:09 EST
*** Bug 1293236 has been marked as a duplicate of this bug. ***
Comment 4 Rex Dieter 2016-01-28 06:52:05 EST
According to the upstream report(s), this should be fixed in plasma-breeze-5.5.4, which we're building now.
Comment 5 Rex Dieter 2016-01-28 06:54:26 EST
*** Bug 1291371 has been marked as a duplicate of this bug. ***
Comment 6 Paul Black 2016-02-03 08:18:54 EST
Tentatively, this seems to be working for me now.
Comment 7 Rex Dieter 2016-02-03 08:24:59 EST
ok, marking as fixed in plasma-breeze-5.5.4

Note You need to log in before you can comment on or make changes to this bug.