Bug 1291427 - [RFE] Add support for auto-attaching only to pools provided by a hypervisor-guest mapping
[RFE] Add support for auto-attaching only to pools provided by a hypervisor-g...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.8
Unspecified Unspecified
low Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: FutureFeature, Triaged
Depends On: 1313045
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-14 15:51 EST by Chris Snyder
Modified: 2017-12-06 05:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1291420
Environment:
Last Closed: 2017-12-06 05:20:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Snyder 2015-12-14 15:51:07 EST
+++ This bug was initially created as a clone of Bug #1291420 +++

Description of problem:
Presently there exists no way to auto attach to virtual pools only.
When consuming subscriptions on a virtualized guest there are often times that a subscription is provided simply by being associated with a particular hypervisor.
It seems there is no way to capture the intent to consume only the subscription provided due to the relationship between the guest and the host.


Actual results:
It is not possible to auto attach just virtual pools (without specifying which pools to use).

There is no option to specify auto attaching to virtual pools only

Expected results:
It is possible to auto attach just from virtual pools (without specifying which pools to use).

There is an option that modifies auto attach to look only at virtual pools from the hypervisor.

ex.
`subscription-manager attach --auto --from-hypervisor`
Comment 2 Jan Kurik 2017-12-06 05:20:09 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.