Bug 1291465 - Main area of UI pushed up when clicking on certain tree nodes
Main area of UI pushed up when clicking on certain tree nodes
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Martin Hradil
Dmitry Misharov
ui
: ZStream
: 1300093 (view as bug list)
Depends On:
Blocks: 1311607
  Show dependency treegraph
 
Reported: 2015-12-14 17:16 EST by Eric Winchell
Modified: 2016-06-29 11:20 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1311607 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:20:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reporting (395.42 KB, image/png)
2015-12-14 17:16 EST, Eric Winchell
no flags Details
VMs (417.87 KB, image/png)
2015-12-14 17:16 EST, Eric Winchell
no flags Details

  None (edit)
Description Eric Winchell 2015-12-14 17:16:07 EST
Created attachment 1105744 [details]
reporting

Description of problem:

Central area of screen (trees, toolbar) is pushed upward under the nav bar when clicking on certain tree nodes and then refreshing.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. go to a lower node on a tree (like the last node on under "My Company" (see screenshots)
2. click refresh
3.

Actual results:

Entire main area of the screen (tree, toolbar, etc) is pushed up into the nav bar


Expected results:

screen content shouldn't shift upward

Additional info:
Comment 2 Eric Winchell 2015-12-14 17:16 EST
Created attachment 1105745 [details]
VMs
Comment 5 CFME Bot 2015-12-18 13:06:41 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/093058562dbae666ebfdab1c559fd3c9af11d643

commit 093058562dbae666ebfdab1c559fd3c9af11d643
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Wed Dec 16 17:09:53 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Wed Dec 16 17:09:53 2015 +0000

    Fix top of the main UI dissapearing behind menus
    
    As far as I can tell, it looks more like a browser bug (except consistent at least between Firefox and Chrome) in that an element with overflow:hidden and height:100% can actually get a non-zero scrollTop value - it seems to happen while rendering, when center_div is taller than the actual available space.
    
    (And I've verified we're not setting the non-zero scrollTop ourselves.)
    
    The simples fix is actually to simply trigger a browser resize event (but triggering just the handlers does not work), shifting the window size by a pixel fixes it, but that's not quite portable.
    
    Thus, this adds an unconditional `$('.container-fluid').scrollTop(0)` to the content layout, which fixes it.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291465

 app/views/layouts/_content.html.haml | 4 ++++
 1 file changed, 4 insertions(+)
Comment 6 Martin Hradil 2016-01-22 11:38:22 EST
*** Bug 1300093 has been marked as a duplicate of this bug. ***
Comment 7 CFME Bot 2016-02-29 09:40:59 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8c27047f2ae1a150002b6f5aa5548423e126f83c

commit 8c27047f2ae1a150002b6f5aa5548423e126f83c
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Wed Dec 16 17:09:53 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Fri Feb 26 21:03:30 2016 +0000

    Fix top of the main UI dissapearing behind menus
    
    As far as I can tell, it looks more like a browser bug (except consistent at least between Firefox and Chrome) in that an element with overflow:hidden and height:100% can actually get a non-zero scrollTop value - it seems to happen while rendering, when center_div is taller than the actual available space.
    
    (And I've verified we're not setting the non-zero scrollTop ourselves.)
    
    The simples fix is actually to simply trigger a browser resize event (but triggering just the handlers does not work), shifting the window size by a pixel fixes it, but that's not quite portable.
    
    Thus, this adds an unconditional `$('.container-fluid').scrollTop(0)` to the content layout, which fixes it.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291465
    (cherry picked from commit 093058562dbae666ebfdab1c559fd3c9af11d643)

 app/views/layouts/_content.html.haml | 4 ++++
 1 file changed, 4 insertions(+)
Comment 8 CFME Bot 2016-02-29 09:41:12 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=053c0ddd3dd60cea5790a3e7868ea15830e2d0da

commit 053c0ddd3dd60cea5790a3e7868ea15830e2d0da
Merge: 1b19cfa 8c27047
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Feb 29 09:38:11 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Feb 29 09:38:11 2016 -0500

    Merge branch 'bz1311607-scrolltop-55' into '5.5.z'
    
    Fix top of the main UI dissapearing behind menus
    
    PR: https://github.com/ManageIQ/manageiq/pull/5869
    
    As far as I can tell, it looks more like a browser bug (except consistent at least between Firefox and Chrome) in that an element with overflow:hidden and height:100% can actually get a non-zero scrollTop value - it seems to happen while rendering, when center_div is taller than the actual available space.
    
    (And I've verified we're not setting the non-zero scrollTop ourselves.)
    
    The simplest fix is actually to simply trigger a browser resize event (but triggering just the handlers does not work), shifting the window size by a pixel fixes it, but that's not quite portable.
    
    Thus, this adds an unconditional $('.container-fluid').scrollTop(0) to the content layout, which fixes it.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291465
    
    Also piggy-backing an almost-related fix to a prototype->jquery conversion bug - replacing render_flash { |page| page << '$(\'#main_div\').scrollTop();' } which does nothing (as opposed to ...scrollTop(0)) with a render_flash_and_scroll helper which does the right thing.
    
    ---
    
    5.5 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1311607
    clean cherry pick
    
    See merge request !815

 app/controllers/application_controller.rb               |  8 +++++++-
 app/controllers/application_controller/ci_processing.rb | 12 ++++++------
 app/views/layouts/_content.html.haml                    |  4 ++++
 3 files changed, 17 insertions(+), 7 deletions(-)
Comment 9 Dmitry Misharov 2016-04-18 05:17:55 EDT
Verified fixed in 5.6.0.1-beta2.20160413141124_e25ac0e.
Comment 11 errata-xmlrpc 2016-06-29 11:20:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.