This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 129152 - window titles no longer change when su'd or ssh'd
window titles no longer change when su'd or ssh'd
Status: CLOSED DUPLICATE of bug 129115
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-04 10:50 EDT by Joshua M. Thompson
Modified: 2014-03-16 22:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua M. Thompson 2004-08-04 10:50:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
As of the latest gnome-terminal update my window titles no longer
change  if I "su -" to another user, ssh to a remote server or use
"screen."


Version-Release number of selected component (if applicable):
gnome-terminal-2.7.3-1

How reproducible:
Always

Steps to Reproduce:
1. Open a terminal window
2. ssh to a remote FC server

    

Actual Results:  Window title will still reflect the last local shell
prompt

Expected Results:  The window title should change to reflect the
command prompt on the remote system.

Additional info:

This broke when gnome-terminal went from 2.6.x to 2.7.x.
Comment 1 James Laska 2004-08-06 10:06:36 EDT
Confirming this bug in latest rawhide (08/06/2004) using
gnome-terminal-2.7.3-1.  This is deemed not to be an ncurses issue,
but rather as Joshua suggests a regression from 2.6.x -> 2.7.x.  I
believe the problem is just a basic terminal window setting.  Starting
a new tab, ssh, screen ... all fail to set the gnome-terminal title. 
xterm does not exhibit this problem.

Thoughts?
Comment 2 Ray Strode [halfline] 2004-08-06 14:48:19 EDT
This has to do with the change made from bug 122815, where
gnome-terminal gets TERM=gnome now instead of TERM=xterm.  

/etc/bashrc only sets the title on terminals that have TERM types that
start with xterm.
Comment 3 Joshua M. Thompson 2004-08-06 14:58:10 EDT
Aha! Setting my TERM type in my personal .bashrc fixes it. Thank the
gods; it was getting annoying not being able to tell my windows apart
by title. :)

I'm not so sure this is a good change though. Not only does it break
the /etc/bashrc script on older servers (think ssh-ing into a remote
server you don't have control over) but it also seems to break
terminal emulation on older systems too. I was having weird isues with
the delete key not working right when running vim over ssh to my dev
server (it runs FC1) and changing my term to "xterm" has cured that too.
Comment 4 Bill Nottingham 2004-08-10 16:40:17 EDT

*** This bug has been marked as a duplicate of 129115 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:04:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.