Bug 1291603 - [tiering]: read/write freq-threshold allows negative values
[tiering]: read/write freq-threshold allows negative values
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Joseph Elwin Fernandes
bugs@gluster.org
: Triaged, ZStream
Depends On: 1291052
Blocks: 1292359
  Show dependency treegraph
 
Reported: 2015-12-15 04:13 EST by Joseph Elwin Fernandes
Modified: 2016-06-16 09:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1291052
: 1292359 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:50:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-15 04:15:25 EST
REVIEW: http://review.gluster.org/12970 (tier/glusterd: Only positive values for freq-thresholds) posted (#2) for review on master by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-15 22:08:45 EST
REVIEW: http://review.gluster.org/12970 (tier/glusterd: Only positive values for freq-thresholds) posted (#3) for review on master by Joseph Fernandes
Comment 3 Vijay Bellur 2015-12-16 09:45:34 EST
COMMIT: http://review.gluster.org/12970 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 4eb7c968a682e59d97efcbc2afa41690dfdd22a2
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Dec 15 14:39:25 2015 +0530

    tier/glusterd: Only positive values for freq-thresholds
    
    Fixed error handling for validation for freq-thresholds
    
    Change-Id: Ibe3a9752ac0b525b0c8c0d6c4b4e4d694bd91b88
    BUG: 1291603
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/12970
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:50:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.