Bug 1292359 - [tiering]: read/write freq-threshold allows negative values
[tiering]: read/write freq-threshold allows negative values
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: Triaged, ZStream
Depends On: 1291052 1291603
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 03:18 EST by Joseph Elwin Fernandes
Modified: 2016-04-19 03:51 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1291603
Environment:
Last Closed: 2016-04-19 03:51:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-17 03:20:15 EST
REVIEW: http://review.gluster.org/12992 (tier/glusterd: Only positive values for freq-thresholds) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-17 16:14:02 EST
COMMIT: http://review.gluster.org/12992 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 459314829691e3cb0c31f4971111d7dadfb199d8
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Dec 15 14:39:25 2015 +0530

    tier/glusterd: Only positive values for freq-thresholds
    
    Fixed error handling for validation for freq-thresholds
    
    Backport of http://review.gluster.org/12970
    
    > Change-Id: Ibe3a9752ac0b525b0c8c0d6c4b4e4d694bd91b88
    > BUG: 1291603
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12970
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: I044284b5134a685e505a377028bc9a11563b2665
    BUG: 1292359
    Reviewed-on: http://review.gluster.org/12992
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:51:26 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.