Bug 1291707 - Service request to "Reconfigure this service" fails with error
Service request to "Reconfigure this service" fails with error
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.3
Assigned To: Harpreet Kataria
Shveta
service:reconfigure
: ZStream
Depends On: 1221333
Blocks: 1223892
  Show dependency treegraph
 
Reported: 2015-12-15 08:25 EST by John Prause
Modified: 2016-04-13 14:40 EDT (History)
12 users (show)

See Also:
Fixed In Version: 5.5.3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1221333
Environment:
Last Closed: 2016-04-13 14:40:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 CFME Bot 2015-12-17 16:24:30 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1c638030576e15614031f0560c1823fdcf57f614

commit 1c638030576e15614031f0560c1823fdcf57f614
Merge: 0754121 ee9bb23
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Dec 17 15:58:50 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Dec 17 15:58:50 2015 -0500

    Merge branch '55z_pr_5838' into '5.5.z'
    
    Fixed code to redirect to Requests list after dialog is submitted.
    
    - Added spec test to verify redirect.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1221333
    https://bugzilla.redhat.com/show_bug.cgi?id=1291707
    (cherry picked from commit dbdae84)
    
    @dclarizi please review, this is clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/5838
    
    See merge request !635

 .../application_controller/dialog_runner.rb        | 14 +++++--------
 .../application_controller/dialog_runner_spec.rb   | 24 ++++++++++++++++++++++
 2 files changed, 29 insertions(+), 9 deletions(-)
Comment 5 CFME Bot 2015-12-17 16:24:45 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ee9bb232c141f040aea772d0623ab0f7768c36d8

commit ee9bb232c141f040aea772d0623ab0f7768c36d8
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Dec 14 14:27:24 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Dec 17 10:06:01 2015 -0500

    Fixed code to redirect to Requests list after dialog is submitted.
    
    - Added spec test to verify redirect.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1221333
    https://bugzilla.redhat.com/show_bug.cgi?id=1291707
    (cherry picked from commit dbdae84)

 .../application_controller/dialog_runner.rb        | 14 +++++--------
 .../application_controller/dialog_runner_spec.rb   | 24 ++++++++++++++++++++++
 2 files changed, 29 insertions(+), 9 deletions(-)
Comment 9 Tina Fitzgerald 2016-03-28 14:12:16 EDT
Automate is not configured for auto-approval for service reconfigure. The "Pending Approval" state is expected.
Comment 10 Vadim Rutkovsky 2016-03-29 03:56:17 EDT
(In reply to Tina Fitzgerald from comment #9)
> Automate is not configured for auto-approval for service reconfigure. The
> "Pending Approval" state is expected.

I see, I guess we can consider this verified. Dave?
Comment 11 Shveta 2016-03-31 15:41:00 EDT
Verified in 5.5.3.2.20160318152106_92d2d67
Comment 13 errata-xmlrpc 2016-04-13 14:40:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0616

Note You need to log in before you can comment on or make changes to this bug.