Bug 1291859 - Getting an error in the UI when moving an unsaved element in a service dialog
Getting an error in the UI when moving an unsaved element in a service dialog
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.4
Assigned To: Jozef Zigmund
Shveta
: ZStream
Depends On: 1238721
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 13:04 EST by John Prause
Modified: 2016-05-31 09:40 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.5.4.0
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, service dialog elements could not be reordered. Attempting to move an unsaved element in a service dialog resulted in an error message on the user interface. This patch uses item order number instead of record ID (unsaved element doesn't have ID) which has now resolved the issue.
Story Points: ---
Clone Of: 1238721
Environment:
Last Closed: 2016-05-31 09:40:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 CFME Bot 2016-04-21 13:47:07 EDT
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=823db0710cb5c051308dd95ee45d5a62f14d6ea1

commit 823db0710cb5c051308dd95ee45d5a62f14d6ea1
Merge: a6e7de3 0076628
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Apr 21 13:31:58 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Apr 21 13:31:58 2016 -0400

    Merge branch 'bz1291859-fix_moving_unsaved_element' into '5.5.z'
    
    Fix the error when user reorders an unsaved element in a service dialog
    
    Cherry-picked bugfix for:
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291859
    
    See merge request !897

 app/assets/javascripts/miq_application.js            | 11 +++++++++++
 .../miq_ae_customization_controller/dialogs.rb       | 20 ++++++++++++++++----
 spec/javascripts/miq_application_spec.js             | 15 +++++++++++++++
 3 files changed, 42 insertions(+), 4 deletions(-)
Comment 6 Shveta 2016-05-03 13:15:41 EDT
Fixed .
verified in 5.5.4.0.20160426160942_629f93b
Comment 8 errata-xmlrpc 2016-05-31 09:40:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1101

Note You need to log in before you can comment on or make changes to this bug.