Bug 1291879 - IPA client install fails due to bad hostname localhost.localdomain [NEEDINFO]
IPA client install fails due to bad hostname localhost.localdomain
Status: CLOSED DUPLICATE of bug 1360928
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: Gregg Tanzillo
Pete Savage
appliance:ldap:error
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 14:30 EST by Pete Savage
Modified: 2017-12-05 10:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-02 15:27:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dajohnso: needinfo? (psavage)


Attachments (Terms of Use)

  None (edit)
Description Pete Savage 2015-12-15 14:30:32 EST
Description of problem: IPA client install fails due to bad hostname localhost.localdomain


Version-Release number of selected component (if applicable): 5.5.0.13


How reproducible: 100%


Steps to Reproduce:
1. Deploy appliance
2. Manually set hostname in the black console
3. Try to run the External httpd configuration

Actual results: Fails with localhost.localdomain is not a valid hostname


Expected results: The hostname that was set should be picked up


Additional info:
If the hostname passed to the installer is left blank, then the IPA installer uses socket.getfqdn() in python. This in turn, due to the lack of an arg, will get the hostname for 127.0.0.1, which will be the first hostname with a . in it, as listed in /etc/hosts. On a RHEL based system this will be, localhost.localdomain. This domain name is invalid in ipa and cannot be used with the installer. It should pick up the set hostname, a PR for this is outlined here,

https://github.com/ManageIQ/manageiq/pull/5854
Comment 2 Nick Carboni 2015-12-16 09:58:15 EST
This is only an issue if the hostname set doesn't have a '.' in it.

See https://github.com/ManageIQ/manageiq/pull/5854 for details.
Comment 3 Dave Johnson 2016-01-26 20:57:59 EST
Pete, does a workaround exist for this one?  I assume if we set the hostname to something resolvable, we are ok?
Comment 4 Dmitry Misharov 2016-01-29 04:12:37 EST
I believe it's fixed and verified in https://bugzilla.redhat.com/show_bug.cgi?id=1287853 Also there is some another catch with IPA https://bugzilla.redhat.com/show_bug.cgi?id=1292146
Comment 5 Nick Carboni 2016-12-02 15:27:33 EST

*** This bug has been marked as a duplicate of bug 1360928 ***

Note You need to log in before you can comment on or make changes to this bug.