Bug 1291946 - [RFE] Support for co-located ceph-osd and nova-compute (Hyper-converged)
Summary: [RFE] Support for co-located ceph-osd and nova-compute (Hyper-converged)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: beta
: 10.0 (Newton)
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
URL:
Whiteboard:
: 1232959 1289137 1314783 (view as bug list)
Depends On: 1364478
Blocks: 1265219 1291943 1299906 1273812 1335593
TreeView+ depends on / blocked
 
Reported: 2015-12-15 23:03 UTC by Neil Levine
Modified: 2017-03-09 11:10 UTC (History)
21 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.0.0-0.20160817161003.bacc2c6.el7ost
Doc Type: Technology Preview
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:19:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
RDO 2857 None None None 2016-10-03 15:10:05 UTC
OpenStack gerrit 304692 None None None 2016-08-10 15:15:17 UTC
Red Hat Bugzilla 1365963 None CLOSED [RFE] Implement resource management for co-located ceph-osd and nova-compute 2019-03-05 14:17:43 UTC

Internal Links: 1364478 1365963 1368241 1481061

Description Neil Levine 2015-12-15 23:03:42 UTC
As an admin, I choose a “hyper-converged with resource management” mode which installs the Ceph-OSD and nova-compute on the same host and configures memory and CPU settings to manage resources.

As an admin, I choose to upgrade my hyper-converged nodes as a single entity.

Comment 5 Sean Cohen 2016-05-09 20:40:52 UTC
*** Bug 1289137 has been marked as a duplicate of this bug. ***

Comment 7 Sean Cohen 2016-07-12 12:18:10 UTC
*** Bug 1232959 has been marked as a duplicate of this bug. ***

Comment 9 Giulio Fidente 2016-08-09 12:10:59 UTC
This is in testing stage upstream now, using composable roles.

Comment 10 John Fulton 2016-08-10 15:37:07 UTC
The resource management component of this BZ has been broken into a separate BZ, which is: https://bugzilla.redhat.com/show_bug.cgi?id=1365963

Comment 13 Giulio Fidente 2016-09-23 12:30:56 UTC
This is possible adding:

  -e environments/hyperconverged-ceph.yaml

to the deploy commandline.

Comment 14 John Fulton 2016-10-03 16:15:44 UTC
FYI: environments/hyperconverged-ceph.yaml depends on python-heatclient 1.5 or newer. As per https://review.rdoproject.org/r/#/c/2857 said heatclient is merged in RDO (however there's a slight upstream divergence here which should get fixed too https://review.rdoproject.org/r/#/c/2857).

Comment 15 John Fulton 2016-10-05 15:30:27 UTC
*** Bug 1314783 has been marked as a duplicate of this bug. ***

Comment 18 errata-xmlrpc 2016-12-14 15:19:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.