Bug 1292034 - nfs-ganesha installation : no pacemaker package installed for RHEL 6.7
nfs-ganesha installation : no pacemaker package installed for RHEL 6.7
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-nfs (Show other bugs)
3.1
All Linux
high Severity high
: ---
: RHGS 3.1.3
Assigned To: Kaleb KEITHLEY
Shashank Raj
: ZStream
: 1245503 (view as bug list)
Depends On:
Blocks: 1299184 1322801 1322808
  Show dependency treegraph
 
Reported: 2015-12-16 04:46 EST by Vivek Das
Modified: 2016-11-07 22:52 EST (History)
17 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-3
Doc Type: Bug Fix
Doc Text:
The glusterfs-ganesha package did not list dependencies for several required packages: cman, pacemaker, and corosync. These dependencies have now been added to the glusterfs-ganesha spec file to ensure these dependencies are included.
Story Points: ---
Clone Of:
: 1322801 (view as bug list)
Environment:
Last Closed: 2016-06-23 00:59:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vivek Das 2015-12-16 04:46:06 EST
Description of problem:
On nfs-ganesha installation the pacemaker package is not available for latest RHEL 6.7 ISO

Version-Release number of selected component (if applicable):
glusterfs-ganesha-3.7.5-11
nfs-ganesha2.2.0.2-4

How reproducible:
Always

Steps to Reproduce:
1. Installed RHEL 6.7 ISO
2. Took the latest Puddles (nfs server & nfs external)
3. yum install nfs-ganesha
4. yum install glusterfs-ganesha
5. rpm -qa | grep pacemaker

Actual results:
Pacemaker package not found after nfs-ganesha installation

Expected results:
Pacemaker package should be present after installation

Additional info:
Comment 2 Sreenath G 2015-12-21 07:50:01 EST
If RHEL 6.7 ISO is installed (ie layered install), then RHEL HA channel need to be subscribed to get pacemaker package.

Otherwise if the installation is from RHGSS-3.1u2-RHEL-6 ISO, then pacemaker-1.1.12-8.el6 is present as an optional package under pkg-group "RH-Gluster-Core"
Comment 4 Niels de Vos 2016-01-27 06:37:01 EST
The prerequisites are described in the documentation. We should still add an explicit dependency on pacemaker/corosync in glusterfs-ganesha.

Possibly also file a bug to fix the dependencies in the pcs (RHEL) package.
Comment 5 Niels de Vos 2016-03-07 05:50:25 EST
*** Bug 1245503 has been marked as a duplicate of this bug. ***
Comment 6 Apeksha 2016-03-07 05:56:36 EST
we also need to check for cman package as a dependency when we do a yum install glusterfs-ganesha
Comment 8 Soumya Koduri 2016-04-12 07:22:21 EDT
Fix : https://code.engineering.redhat.com/gerrit/#/c/71967/
Comment 9 Milind Changire 2016-04-29 03:00:27 EDT
Patch in comment #8 has been merged.
Moving to MODIFIED.
Comment 11 Shashank Raj 2016-05-03 10:16:45 EDT
Verified this bug with glusterfs-3.7.9-3 build and on RHEL 6.8 platform and below are the results:

Steps to verify:

1. Installed RHEL 6.8
2. subscribed to below RHEL 6 base channels:

subscription-manager repos --enable=rhel-6-server-rpms --enable=rhel-scalefs-for-rhel-6-server-rpms --enable=rhs-3-for-rhel-6-server-rpms --enable=rh-gluster-3-nfs-for-rhel-6-server-rpms

3. Added 3.7.9-3 puddles as below:

[root@dhcp43-228 yum.repos.d]# ll
total 308
-rw-r--r--. 1 root root    612 May  3 11:29 external-RH-Gluster-3-NFS.repo
-rw-r--r--. 1 root root    661 May  3 11:29 external-RH-Gluster-3-Server.repo
-rw-r--r--. 1 root root 293742 May  4 00:04 redhat.repo
-rw-r--r--. 1 root root    529 Apr 14 16:19 rhel-source.repo
-rw-r--r--. 1 root root    560 May  3 11:29 RH-Gluster-3-NFS.repo
-rw-r--r--. 1 root root    587 May  3 11:29 RH-Gluster-3-Server.repo

4. Do a yum install glusterfs-ganesha

[root@dhcp43-228 yum.repos.d]# yum install glusterfs-ganesha
.
.
.
.

Dependencies Resolved

===================================================================================
 Package     Arch   Version           Repository                              Size
===================================================================================
Installing:
 glusterfs-ganesha
             x86_64 3.7.9-3.el6rhs    External-RH-Gluster-3-NFS-Repository-3  19 k
Installing for dependencies:
 ccs         x86_64 0.16.2-81.el6     External-RH-Gluster-3-NFS-Repository-1  53 k
 clusterlib  x86_64 3.0.12.1-73.el6_7.2
                                      External-RH-Gluster-3-NFS-Repository-1 106 k
 cman        x86_64 3.0.12.1-73.el6_7.2
                                      External-RH-Gluster-3-NFS-Repository-1 450 k
 compat-readline5
             x86_64 5.2-17.1.el6      External-RH-Gluster-3-NFS-Repository-1 128 k
 corosync    x86_64 1.4.7-2.el6       External-RH-Gluster-3-NFS-Repository-1 213 k
 corosynclib x86_64 1.4.7-2.el6       External-RH-Gluster-3-NFS-Repository-1 191 k
 cyrus-sasl-md5
             x86_64 2.1.23-15.el6_6.2 External-RH-Gluster-3-NFS-Repository-1  46 k
 fence-agents
             x86_64 4.0.15-8.el6_7.2  External-RH-Gluster-3-NFS-Repository-1 188 k
 fence-virt  x86_64 0.2.3-19.el6      External-RH-Gluster-3-NFS-Repository-1  37 k
 gnutls-utils
             x86_64 2.8.5-19.el6_7    External-RH-Gluster-3-NFS-Repository-1 100 k
 ipmitool    x86_64 1.8.11-29.el6_7   External-RH-Gluster-3-NFS-Repository-1 463 k
 libibverbs  x86_64 1.1.8-4.el6       External-RH-Gluster-3-NFS-Repository-1  52 k
 libntirpc   x86_64 1.3.1-1.el6rhs    External-RH-Gluster-3-NFS-Repository-3 112 k
 libqb       x86_64 0.17.1-1.el6      External-RH-Gluster-3-NFS-Repository-1  70 k
 librdmacm   x86_64 1.0.19.1-1.1.el6_7
                                      External-RH-Gluster-3-NFS-Repository-1  58 k
 libtool-ltdl
             x86_64 2.2.6-15.5.el6    External-RH-Gluster-3-NFS-Repository-1  43 k
 libvirt-client
             x86_64 0.10.2-54.el6_7.6 External-RH-Gluster-3-NFS-Repository-1 4.1 M
 lm_sensors-libs
             x86_64 3.1.1-17.el6      External-RH-Gluster-3-NFS-Repository-1  37 k
 modcluster  x86_64 0.16.2-31.el6     External-RH-Gluster-3-NFS-Repository-1 191 k
 nc          x86_64 1.84-24.el6       External-RH-Gluster-3-NFS-Repository-1  56 k
 net-snmp-libs
             x86_64 1:5.5-54.el6_7.1  External-RH-Gluster-3-NFS-Repository-1 1.5 M
 net-snmp-utils
             x86_64 1:5.5-54.el6_7.1  External-RH-Gluster-3-NFS-Repository-1 175 k
 nfs-ganesha x86_64 2.3.1-4.el6rhs    External-RH-Gluster-3-NFS-Repository-3 471 k
 nfs-ganesha-gluster
             x86_64 2.3.1-4.el6rhs    External-RH-Gluster-3-NFS-Repository-3  32 k
 openais     x86_64 1.1.1-7.el6       External-RH-Gluster-3-NFS-Repository-1 191 k
 openaislib  x86_64 1.1.1-7.el6       External-RH-Gluster-3-NFS-Repository-1  81 k
 pacemaker   x86_64 1.1.12-8.el6_7.2  External-RH-Gluster-3-NFS-Repository-1 440 k
 pacemaker-cli
             x86_64 1.1.12-8.el6_7.2  External-RH-Gluster-3-NFS-Repository-1 203 k
 pacemaker-cluster-libs
             x86_64 1.1.12-8.el6_7.2  External-RH-Gluster-3-NFS-Repository-1  80 k
 pacemaker-libs
             x86_64 1.1.12-8.el6_7.2  External-RH-Gluster-3-NFS-Repository-1 460 k
 pcs         x86_64 0.9.139-9.el6_7.2 External-RH-Gluster-3-NFS-Repository-1 5.8 M
 perl-Net-Telnet
             noarch 3.03-11.el6       External-RH-Gluster-3-NFS-Repository-1  54 k
 perl-TimeDate
             noarch 1:1.16-13.el6     External-RH-Gluster-3-NFS-Repository-1  36 k
 pexpect     noarch 2.3-6.el6         External-RH-Gluster-3-NFS-Repository-1 146 k
 python-clufter
             x86_64 0.11.2-1.el6      External-RH-Gluster-3-NFS-Repository-1 295 k
 python-suds noarch 0.4.1-3.el6       External-RH-Gluster-3-NFS-Repository-1 217 k
 resource-agents
             x86_64 3.9.5-24.el6_7.1  External-RH-Gluster-3-NFS-Repository-1 364 k
 ricci       x86_64 0.16.2-81.el6     External-RH-Gluster-3-NFS-Repository-1 631 k
 ruby        x86_64 1.8.7.374-4.el6_6 External-RH-Gluster-3-NFS-Repository-1 537 k
 ruby-irb    x86_64 1.8.7.374-4.el6_6 External-RH-Gluster-3-NFS-Repository-1 316 k
 ruby-libs   x86_64 1.8.7.374-4.el6_6 External-RH-Gluster-3-NFS-Repository-1 1.7 M
 ruby-rdoc   x86_64 1.8.7.374-4.el6_6 External-RH-Gluster-3-NFS-Repository-1 380 k
 rubygems    noarch 1.3.7-5.el6       External-RH-Gluster-3-NFS-Repository-1 206 k
 sg3_utils   x86_64 1.28-10.el6_7     External-RH-Gluster-3-NFS-Repository-1 499 k
 telnet      x86_64 1:0.17-48.el6     External-RH-Gluster-3-NFS-Repository-1  57 k
 yajl        x86_64 1.0.7-3.el6       External-RH-Gluster-3-NFS-Repository-1  26 k

Transaction Summary
===================================================================================
Install      47 Package(s)

Total download size: 21 M
Installed size: 65 M
Is this ok [y/N]: y

.
.
.

Installed:
  glusterfs-ganesha.x86_64 0:3.7.9-3.el6rhs                                        

Dependency Installed:
  ccs.x86_64 0:0.16.2-81.el6                                                       
  clusterlib.x86_64 0:3.0.12.1-73.el6_7.2                                          
  cman.x86_64 0:3.0.12.1-73.el6_7.2                                                
  compat-readline5.x86_64 0:5.2-17.1.el6                                           
  corosync.x86_64 0:1.4.7-2.el6                                                    
  corosynclib.x86_64 0:1.4.7-2.el6                                                 
  cyrus-sasl-md5.x86_64 0:2.1.23-15.el6_6.2                                        
  fence-agents.x86_64 0:4.0.15-8.el6_7.2                                           
  fence-virt.x86_64 0:0.2.3-19.el6                                                 
  gnutls-utils.x86_64 0:2.8.5-19.el6_7                                             
  ipmitool.x86_64 0:1.8.11-29.el6_7                                                
  libibverbs.x86_64 0:1.1.8-4.el6                                                  
  libntirpc.x86_64 0:1.3.1-1.el6rhs                                                
  libqb.x86_64 0:0.17.1-1.el6                                                      
  librdmacm.x86_64 0:1.0.19.1-1.1.el6_7                                            
  libtool-ltdl.x86_64 0:2.2.6-15.5.el6                                             
  libvirt-client.x86_64 0:0.10.2-54.el6_7.6                                        
  lm_sensors-libs.x86_64 0:3.1.1-17.el6                                            
  modcluster.x86_64 0:0.16.2-31.el6                                                
  nc.x86_64 0:1.84-24.el6                                                          
  net-snmp-libs.x86_64 1:5.5-54.el6_7.1                                            
  net-snmp-utils.x86_64 1:5.5-54.el6_7.1                                           
  nfs-ganesha.x86_64 0:2.3.1-4.el6rhs                                              
  nfs-ganesha-gluster.x86_64 0:2.3.1-4.el6rhs                                      
  openais.x86_64 0:1.1.1-7.el6                                                     
  openaislib.x86_64 0:1.1.1-7.el6                                                  
  pacemaker.x86_64 0:1.1.12-8.el6_7.2                                              
  pacemaker-cli.x86_64 0:1.1.12-8.el6_7.2                                          
  pacemaker-cluster-libs.x86_64 0:1.1.12-8.el6_7.2                                 
  pacemaker-libs.x86_64 0:1.1.12-8.el6_7.2                                         
  pcs.x86_64 0:0.9.139-9.el6_7.2                                                   
  perl-Net-Telnet.noarch 0:3.03-11.el6                                             
  perl-TimeDate.noarch 1:1.16-13.el6                                               
  pexpect.noarch 0:2.3-6.el6                                                       
  python-clufter.x86_64 0:0.11.2-1.el6                                             
  python-suds.noarch 0:0.4.1-3.el6                                                 
  resource-agents.x86_64 0:3.9.5-24.el6_7.1                                        
  ricci.x86_64 0:0.16.2-81.el6                                                     
  ruby.x86_64 0:1.8.7.374-4.el6_6                                                  
  ruby-irb.x86_64 0:1.8.7.374-4.el6_6                                              
  ruby-libs.x86_64 0:1.8.7.374-4.el6_6                                             
  ruby-rdoc.x86_64 0:1.8.7.374-4.el6_6                                             
  rubygems.noarch 0:1.3.7-5.el6                                                    
  sg3_utils.x86_64 0:1.28-10.el6_7                                                 
  telnet.x86_64 1:0.17-48.el6                                                      
  yajl.x86_64 0:1.0.7-3.el6                                                        

Complete!

As we can see that glusterfs-ganesha in turn installs cman, pacemaker, corosync, pcs, libntirpc and nfs-ganesha packages

cman.x86_64 0:3.0.12.1-73.el6_7.2
corosync.x86_64 0:1.4.7-2.el6
corosynclib.x86_64 0:1.4.7-2.el6
libntirpc.x86_64 0:1.3.1-1.el6rhs 
nfs-ganesha.x86_64 0:2.3.1-4.el6rhs
nfs-ganesha-gluster.x86_64 0:2.3.1-4.el6rhs
pacemaker.x86_64 0:1.1.12-8.el6_7.2
pacemaker-cli.x86_64 0:1.1.12-8.el6_7.2
pacemaker-cluster-libs.x86_64 0:1.1.12-8.el6_7.2
pacemaker-libs.x86_64 0:1.1.12-8.el6_7.2
pcs.x86_64 0:0.9.139-9.el6_7.2   

Based on the above observation, marking this bug as Verified.
Comment 13 Kaleb KEITHLEY 2016-06-06 06:01:11 EDT
doc text looks okay,

thanks
Comment 15 errata-xmlrpc 2016-06-23 00:59:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.