Bug 1292095 (psi+cmake) - [Tracker, RFE] CMake support in psi* packages (psi-plus mostly) and with Qt5
Summary: [Tracker, RFE] CMake support in psi* packages (psi-plus mostly) and with Qt5
Keywords:
Status: CLOSED ERRATA
Alias: psi+cmake
Product: Fedora
Classification: Fedora
Component: psi-plus
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/psi-plus/psi-plus-...
Whiteboard:
Depends On: 1292008 1292093 1292106 1292107
Blocks: 737304
TreeView+ depends on / blocked
 
Reported: 2015-12-16 13:11 UTC by Raphael Groner
Modified: 2018-09-21 05:24 UTC (History)
1 user (show)

Fixed In Version: psi-plus-1.3.408-1.fc28 psi-plus-1.3.408-1.fc29
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-13 19:00:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1279265 None None None Never
Red Hat Bugzilla 1510100 None None None Never

Internal Links: 1279265 1510100

Description Raphael Groner 2015-12-16 13:11:02 UTC
Description of problem:
Tracker bug for CMake support in psi* packages (psi-plus mostly)

Version-Release number of selected component (if applicable):
rawhide

How reproducible:
still

Steps to Reproduce:
1. work on cmake support in psi-plus
2.
3.

Actual results:
see dependent bugs

Expected results:
all dependent bugs are fixed

Additional info:

Comment 1 Raphael Groner 2015-12-16 15:07:26 UTC
https://gitlab.com/rapgro/psi-cmake

Comment 2 Raphael Groner 2015-12-19 14:25:58 UTC
We run into trouble with the plugins centre and I need to poke upstream about the intense patch done here.

https://github.com/psi-plus/main/blob/master/patches/8000-psi-extend-plugins-interface.diff#L1041

https://stackoverflow.com/questions/17503724/building-a-plugin-to-extend-a-qt-application

The reason moc failed was because the interface declaration was unavailable. The #include directive failed because the file could not be found. Apparently, moc can process #include directives by itself, but doesn't (by default?) print an error message or halt processing if the file to be included can't be found.

The reason the header file with the interface declaration could not be found is that the custom build settings which cause moc to be invoked that are generated by the Qt VS add-in don't inherit the project's include path. I managed to add the required path manualy to moc's command line by entering the property pages of the plugin's header file, browsing to Custom Build Tool->General->Command Line and adding an extra "-I..." include option at the end. After that, moc processed the header and the build was successfull.

Comment 3 Raphael Groner 2015-12-24 10:10:18 UTC
https://github.com/Vitozz/psi-plus-cmake/

Comment 4 Raphael Groner 2016-01-14 14:15:11 UTC
http://bugzilla.linux.ibm.com/show_bug.cgi?id=131557

404 Page not found

Comment 5 Raphael Groner 2016-01-14 14:15:57 UTC
Comment #4 is spam, sorry wrong bug#.

Comment 6 Raphael Groner 2016-03-28 08:02:29 UTC
Upstream writes:
> 4) compile with libiris shared lib (optional. bundled iris will be available for mac, windows and systems w/o shared libiris)
> 5) release new qconf [almost done]
https://github.com/psi-plus/main/issues/560

Comment 7 Raphael Groner 2017-01-07 18:24:01 UTC
IMHO This should now have more priority. 
Though, the Vitozz project did not work for me.

Comment 8 Raphael Groner 2018-08-13 15:15:54 UTC
Retry with support of upstream:
https://github.com/psi-plus/psi-plus-cmake

Comment 9 Raphael Groner 2018-08-13 15:20:43 UTC
... and upstream has now official support for cmake in the psi-plus-snapshots project.

Comment 10 Fedora Update System 2018-08-30 00:02:30 UTC
psi-plus-1.3.408-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-6ab1654e44

Comment 11 Fedora Update System 2018-08-30 15:00:54 UTC
psi-plus-1.3.408-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-6ab1654e44

Comment 12 Fedora Update System 2018-09-01 08:20:36 UTC
psi-plus-1.3.408-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-18eece808b

Comment 13 Fedora Update System 2018-09-02 06:45:16 UTC
psi-plus-1.3.408-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-18eece808b

Comment 14 Fedora Update System 2018-09-13 19:00:12 UTC
psi-plus-1.3.408-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2018-09-21 05:24:08 UTC
psi-plus-1.3.408-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.