Bug 1292112 - [Tier]: start tier daemon using rebal tier start doesnt start tierd if it is failed on any of single node
[Tier]: start tier daemon using rebal tier start doesnt start tierd if it is ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: ZStream
Depends On: 1276273 1293698
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-12-16 08:57 EST by hari gowtham
Modified: 2016-06-16 09:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1276273
Environment:
Last Closed: 2016-06-16 09:51:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-16 09:00:08 EST
REVIEW: http://review.gluster.org/12983 (Tier: "rebalance tier start force" command implementation) posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-12-17 00:37:54 EST
REVIEW: http://review.gluster.org/12983 (Tier: "rebalance tier start force" command implementation) posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-12-17 01:34:47 EST
REVIEW: http://review.gluster.org/12983 (Tier: "rebalance tier start force" command implementation) posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Vijay Bellur 2015-12-17 05:16:01 EST
REVIEW: http://review.gluster.org/12983 (Tier: "rebalance tier start force" command implementation) posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Vijay Bellur 2015-12-17 09:46:57 EST
REVIEW: http://review.gluster.org/12983 (Tier: "rebalance tier start force" command implementation) posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Vijay Bellur 2015-12-17 10:22:40 EST
REVIEW: http://review.gluster.org/12983 (Tier: "rebalance tier start force" command implementation) posted (#6) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 7 Vijay Bellur 2015-12-18 07:27:47 EST
REVIEW: http://review.gluster.org/12983 (Tier: "rebalance tier start force" command implementation) posted (#7) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 8 Vijay Bellur 2015-12-21 02:10:18 EST
REVIEW: http://review.gluster.org/12983 (Tier: "rebalance tier start force" command implementation) posted (#8) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 9 Vijay Bellur 2015-12-21 07:35:32 EST
REVIEW: http://review.gluster.org/12983 (Tier: "tier start force" command implementation) posted (#9) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 10 Vijay Bellur 2015-12-22 01:45:50 EST
REVIEW: http://review.gluster.org/12983 (Tier: "tier start force" command implementation) posted (#10) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 11 Vijay Bellur 2015-12-22 08:23:12 EST
REVIEW: http://review.gluster.org/12983 (Tier: "tier start force" command implementation) posted (#11) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 12 Vijay Bellur 2015-12-22 10:43:10 EST
REVIEW: http://review.gluster.org/12983 (Tier: "tier start force" command implementation) posted (#12) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 13 Vijay Bellur 2015-12-22 19:24:15 EST
COMMIT: http://review.gluster.org/12983 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 7f61095ddd118d4475df070fbf1f4117bf651ece
Author: hari gowtham <hgowtham@redhat.com>
Date:   Wed Dec 16 16:18:29 2015 +0530

    Tier: "tier start force" command implementation
    
    The start command doesnt restart the tier deamon if the deamon
    is running at one node. hence to bring up the tierd on the nodes
    where the deamon is down, the force command is implemented.
    It skips the check for tierd running.
    
    Change-Id: I0037d3e5ecfe56637d0da201a97903c435d26436
    BUG: 1292112
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12983
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 14 Niels de Vos 2016-06-16 09:51:17 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.