Bug 1293698 - [Tier]: start tier daemon using rebal tier start doesnt start tierd if it is failed on any of single node
[Tier]: start tier daemon using rebal tier start doesnt start tierd if it is ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: ZStream
Depends On: 1276273
Blocks: 1260783 1292112
  Show dependency treegraph
 
Reported: 2015-12-22 13:02 EST by hari gowtham
Modified: 2016-04-19 03:51 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1276273
Environment:
Last Closed: 2016-04-19 03:51:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-22 13:04:24 EST
REVIEW: http://review.gluster.org/13069 (Tier: "tier start force" command implementation) posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-12-22 20:45:04 EST
COMMIT: http://review.gluster.org/13069 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 85d34ea0cf8b687c10093ae06417e498e252e563
Author: hari gowtham <hgowtham@redhat.com>
Date:   Wed Dec 16 16:18:29 2015 +0530

    Tier: "tier start force" command implementation
    
    	back port of : http://review.gluster.org/#/c/12983/
    
    The start command doesnt restart the tier deamon if the deamon
    is running at one node. hence to bring up the tierd on the nodes
    where the deamon is down, the force command is implemented.
    It skips the check for tierd running.
    
    >Change-Id: I0037d3e5ecfe56637d0da201a97903c435d26436
    >BUG: 1292112
    >Signed-off-by: hari gowtham <hgowtham@redhat.com>
    
    Change-Id: Idaca442c1a41ded8bf555a6e34eed0ebb9ea4034
    BUG: 1293698
    Signed-off-by: hari <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/13069
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:51:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.