Bug 1292141 - Rebase to FreeIPA 4.4+
Rebase to FreeIPA 4.4+
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
Marc Muehlfeld
: Rebase
Depends On: 1340304
Blocks: 1292074 1296125 1313485
  Show dependency treegraph
 
Reported: 2015-12-16 10:03 EST by Martin Kosek
Modified: 2016-11-04 01:47 EDT (History)
8 users (show)

See Also:
Fixed In Version: ipa-4.4.0-0.el7.1.alpha1
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
IdM rebased to version 4.4.0 The _ipa*_ packages have been upgraded to upstream version 4.4.0, which provide a number of bug fixes and enhancements over the previous version: * Improved Identity Management (IdM) server performance, such as faster provisioning, Kerberos authentication, and user and group operations with many members. * DNS locations to enable clients in a branch office to contact only local servers with the possibility to fall back to remote servers. * Central replication topology management. * The number of supported replication partners has been increased from 20 to 60 replicas. * Authentication indicator support for one-time passwords (OTP) and RADIUS. Authentication indicators can be enabled for hosts and services individually. * Sub-CA support enables the administrator to create individual certificate authorities to issue certificates for specific services. * Enhanced smart card support for Active Directory (AD) users enables the administrator to store smart card certificates in AD or IdM overrides. * IdM server API versioning. * Support for establishing external trusts with AD. * Alternative AD user principal names (UPN) suffixes.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 01:47:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kosek 2015-12-16 10:03:01 EST
Rebase IdM in RHEL to the release of upstream FreeIPA, to introduce the new enhancements and stabilization in RHEL.
Comment 4 Kaleem 2016-08-24 10:14:21 EDT
[root@dhcp207-129 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.3 Beta (Maipo)
[root@dhcp207-129 ~]# rpm -qi ipa-server
Name        : ipa-server
Version     : 4.4.0
Release     : 8.el7
Architecture: x86_64
Install Date: Fri 19 Aug 2016 10:26:10 AM IST
Group       : System Environment/Base
Size        : 1019059
License     : GPLv3+
Signature   : (none)
Source RPM  : ipa-4.4.0-8.el7.src.rpm
Build Date  : Wed 17 Aug 2016 09:24:23 PM IST
Build Host  : x86-017.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://www.freeipa.org/
Summary     : The IPA authentication server
Description :
IPA is an integrated solution to provide centrally managed Identity (users,
hosts, services), Authentication (SSO, 2FA), and Authorization
(host access control, SELinux user roles, services). The solution provides
features for further integration with Linux based clients (SUDO, automount)
and integration with Active Directory based infrastructures (Trusts).
If you are installing an IPA server, you need to install this package.
[root@dhcp207-129 ~]#
Comment 14 errata-xmlrpc 2016-11-04 01:47:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html

Note You need to log in before you can comment on or make changes to this bug.