Bug 1292166 - Backport: get_networks performance hindered by segment lookups
Backport: get_networks performance hindered by segment lookups
Status: CLOSED DUPLICATE of bug 1292167
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: lpeer
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 10:52 EST by Haim Daniel
Modified: 2016-07-07 20:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 18:31:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1525423 None None None 2015-12-16 10:52 EST

  None (edit)
Description Haim Daniel 2015-12-16 10:52:23 EST
During the get_networks method of ML2, we iterate over each network and do a database call to lookup the segments for that network. This scales the number of database calls linearly with the number of retrieved networks.
Comment 2 Assaf Muller 2015-12-16 18:31:05 EST

*** This bug has been marked as a duplicate of bug 1292167 ***

Note You need to log in before you can comment on or make changes to this bug.