Bug 1292167 - Backport: get_networks performance hindered by segment lookups
Backport: get_networks performance hindered by segment lookups
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Haim Daniel
Eran Kuris
: Triaged
: 1292166 (view as bug list)
Depends On:
Blocks: 1290562
  Show dependency treegraph
 
Reported: 2015-12-16 10:52 EST by Haim Daniel
Modified: 2016-07-07 20:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-neutron-7.0.1-4
Doc Type: Bug Fix
Doc Text:
Cause: Large number of existing (Networks X Subnets) Consequence: Time it takes to list the networks (net-list) increases greatly with number of existing networks and subnets as a result of multiple database queries. Result: Reduced time for net-list, the operation does an aggregated query for all subnets per network
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:19:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1525423 None None None 2015-12-16 10:52 EST
Red Hat Product Errata RHEA-2016:0603 normal SHIPPED_LIVE Red Hat OpenStack Platform 8 Enhancement Advisory 2016-04-07 20:53:53 EDT

  None (edit)
Description Haim Daniel 2015-12-16 10:52:38 EST
During the get_networks method of ML2, we iterate over each network and do a database call to lookup the segments for that network. This scales the number of database calls linearly with the number of retrieved networks.
Comment 2 Assaf Muller 2015-12-16 18:31:05 EST
*** Bug 1292166 has been marked as a duplicate of this bug. ***
Comment 5 Eran Kuris 2016-01-21 10:56:43 EST
Verified 
(Tempest_run)[stack@instack neutron]$ rpm -qa |grep neutron 
openstack-neutron-common-7.0.1-6.el7ost.noarch
openstack-neutron-7.0.1-6.el7ost.noarch
python-neutron-7.0.1-6.el7ost.noarch
openstack-neutron-ml2-7.0.1-6.el7ost.noarch
openstack-neutron-openvswitch-7.0.1-6.el7ost.noarch
python-neutronclient-3.1.0-1.el7ost.noarch

https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/rhos-unittest-gerrit-neutron-rhel-7.2/719/testReport/
Comment 6 Assaf Muller 2016-02-04 06:09:32 EST
@Haim, since this bug did not affect OSP 7 or earlier versions, it did not affect any existing customers. Since we're fixing it before the first release of OSP 8, it means that no one was affected by the regression, so we don't need doctext (Because there's no one to tell that the issue was fixed).
Comment 7 errata-xmlrpc 2016-04-07 17:19:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.