Bug 1292184 - UI: VM Provisioning - When adding a provisiong request, uploading Sysprep Answer file does not load screen properly
UI: VM Provisioning - When adding a provisiong request, uploading Sysprep Ans...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Milan Zazrivec
Taras Lehinevych
: ZStream
Depends On:
Blocks: 1292194
  Show dependency treegraph
 
Reported: 2015-12-16 11:48 EST by Harpreet Kataria
Modified: 2016-08-02 21:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292194 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harpreet Kataria 2015-12-16 11:48:33 EST
Description of problem:When adding a provisiong request, uploading Sysprep Answer file does not load screen properly


Version-Release number of selected component (if applicable):


How reproducible:100%


Steps to Reproduce:
1. Go to Workload explorer, Press Provision button under Lifecycle
2. Select a windows template, click contnue
3. After filling out fields, switch to Customize tab
4. From Customize drop down select "Sysprep answer File"
5. Select a file to upload in Upload File section, press Upload button

Actual results:
Flash message is displayed with results of upload, but form fields are missing on the screen

Expected results: Flash message with upload results should be displayed along with other form fields.


Additional info:
Comment 1 Harpreet Kataria 2015-12-16 11:49:04 EST
this BZ addresses http://talk.manageiq.org/t/customize-sysprep-answer-file/1099
Comment 2 Harpreet Kataria 2015-12-16 11:55:17 EST
Milan,

I am not sure but maybe https://github.com/ManageIQ/manageiq/blob/master/app/views/miq_request/_prov_field.html.haml#L529 is the culprit. Let me know if you need help looking into this.

Thanks,
~Harpreet
Comment 3 Milan Zazrivec 2015-12-22 09:25:41 EST
https://github.com/ManageIQ/manageiq/pull/5957
Comment 4 CFME Bot 2015-12-23 12:45:50 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/d05c209a99d39473f1187aa6446c6b26f24f6b45

commit d05c209a99d39473f1187aa6446c6b26f24f6b45
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Tue Dec 22 15:22:43 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Tue Dec 22 15:24:32 2015 +0100

    Fix VM provisioning from Services -> Workloads
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292184

 .../application_controller/sysprep_answer_file.rb           |  2 +-
 app/views/miq_request/_prov_edit.html.haml                  | 13 ++++++-------
 app/views/miq_request/prov_edit.html.haml                   |  3 ++-
 app/views/vm_or_template/explorer.html.haml                 |  7 ++++++-
 config/routes.rb                                            |  1 +
 5 files changed, 16 insertions(+), 10 deletions(-)
Comment 5 Taras Lehinevych 2016-05-05 12:26:20 EDT
Verified in 5.6.0.5-beta2.4
Comment 7 errata-xmlrpc 2016-06-29 11:22:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.