Bug 1292194 - UI: VM Provisioning - When adding a provisiong request, uploading Sysprep Answer file does not load screen properly
UI: VM Provisioning - When adding a provisiong request, uploading Sysprep Ans...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.2
Assigned To: Milan Zazrivec
Vadim Rutkovsky
: ZStream
Depends On: 1292184
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 12:09 EST by Chris Pelland
Modified: 2016-02-10 10:28 EST (History)
10 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1292184
Environment:
Last Closed: 2016-02-10 10:28:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Pelland 2015-12-16 12:09:10 EST
+++ This bug was initially created as a clone of Bug #1292184 +++

Description of problem:When adding a provisiong request, uploading Sysprep Answer file does not load screen properly


Version-Release number of selected component (if applicable):


How reproducible:100%


Steps to Reproduce:
1. Go to Workload explorer, Press Provision button under Lifecycle
2. Select a windows template, click contnue
3. After filling out fields, switch to Customize tab
4. From Customize drop down select "Sysprep answer File"
5. Select a file to upload in Upload File section, press Upload button

Actual results:
Flash message is displayed with results of upload, but form fields are missing on the screen

Expected results: Flash message with upload results should be displayed along with other form fields.


Additional info:

--- Additional comment from Harpreet Kataria on 2015-12-16 11:49:04 EST ---

this BZ addresses http://talk.manageiq.org/t/customize-sysprep-answer-file/1099

--- Additional comment from Harpreet Kataria on 2015-12-16 11:55:17 EST ---

Milan,

I am not sure but maybe https://github.com/ManageIQ/manageiq/blob/master/app/views/miq_request/_prov_field.html.haml#L529 is the culprit. Let me know if you need help looking into this.

Thanks,
~Harpreet
Comment 2 CFME Bot 2016-01-05 10:55:31 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=00b549c9722cd851037b9ce1e6345074e21533b3

commit 00b549c9722cd851037b9ce1e6345074e21533b3
Merge: 9682cf7 eebbb18
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Jan 5 10:40:48 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Jan 5 10:40:48 2016 -0500

    Merge branch 'fix_workloads_provisioning' into '5.5.z'
    
    Fix VM provisioning from Services -> Workloads
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292194
    (cherry picked from commit d05c209a99d39473f1187aa6446c6b26f24f6b45)
    
    See merge request !668

 .../application_controller/sysprep_answer_file.rb           |  2 +-
 app/views/miq_request/_prov_edit.html.haml                  | 13 ++++++-------
 app/views/miq_request/prov_edit.html.haml                   |  3 ++-
 app/views/vm_or_template/explorer.html.haml                 |  7 ++++++-
 config/routes.rb                                            |  1 +
 5 files changed, 16 insertions(+), 10 deletions(-)
Comment 3 CFME Bot 2016-01-05 10:55:34 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=eebbb182ebcb865c16b40071aea45be392cab675

commit eebbb182ebcb865c16b40071aea45be392cab675
Author:     Milan Zazrivec <mzazrivec@redhat.com>
AuthorDate: Tue Dec 22 15:22:43 2015 +0100
Commit:     Milan Zazrivec <mzazrivec@redhat.com>
CommitDate: Tue Jan 5 15:34:43 2016 +0100

    Fix VM provisioning from Services -> Workloads
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292194
    (cherry picked from commit d05c209a99d39473f1187aa6446c6b26f24f6b45)

 .../application_controller/sysprep_answer_file.rb           |  2 +-
 app/views/miq_request/_prov_edit.html.haml                  | 13 ++++++-------
 app/views/miq_request/prov_edit.html.haml                   |  3 ++-
 app/views/vm_or_template/explorer.html.haml                 |  7 ++++++-
 config/routes.rb                                            |  1 +
 5 files changed, 16 insertions(+), 10 deletions(-)
Comment 5 Vadim Rutkovsky 2016-01-19 05:33:12 EST
Verified on 5.5.2.1
Comment 6 errata-xmlrpc 2016-02-10 10:28:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.